Closed Bug 1157201 Opened 6 years ago Closed 6 years ago

regression: rule-view error message on hover "isValidHoverTarget rejected with an unexpected reason"

Categories

(DevTools :: Inspector, defect)

defect
Not set
normal

Tracking

(firefox40 fixed)

RESOLVED FIXED
Firefox 40
Tracking Status
firefox40 --- fixed

People

(Reporter: pbro, Assigned: ochameau)

References

Details

Attachments

(1 file)

STR:
- Use a recent fx-team build (I don't know when this started, but I see it today, wasn't seeing it yesterday, at least I didn't notice it).
- Open the inspector on any page.
- Move your mouse over the rule-view area.
- Watch the browser console or terminal output.

Errors are being logged at each mousemove:

console.error: 
  isValidHoverTarget rejected with an unexpected reason:
console.error: 
undefined
A candidate could be bug 1022765.
Depends on: 1022765
Attached patch patchSplinter Review
Oops, I forgot to ensure the other usages of Tooltip conformed to
startTogglingOnHover exceptations (the callback should reject `false`, 
otherwise it is considered as an error and logged).

May be we could ease that to any falsy rejection value?

https://treeherder.mozilla.org/#/jobs?repo=try&revision=976a9a88de35
Assignee: nobody → poirot.alex
Attachment #8595983 - Flags: review?(pbrosset)
Comment on attachment 8595983 [details] [diff] [review]
patch

Review of attachment 8595983 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Alex for picking that up quickly. Also my bad for not having seen this coming when reviewing the other bug.
Attachment #8595983 - Flags: review?(pbrosset) → review+
Duplicate of this bug: 1158308
https://hg.mozilla.org/mozilla-central/rev/0ca15d7656bf
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.