Closed Bug 1157523 Opened 5 years ago Closed 4 years ago

Intermittent browser_perf-columns-memory-calltree.js,browser_perf-refresh.js | leaked 2 window(s) until shutdown [url = doc_simple-test.html]

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P1)

defect

Tracking

(firefox38 unaffected, firefox38.0.5 unaffected, firefox39 unaffected, firefox40 disabled, firefox41 disabled, firefox-esr31 unaffected)

RESOLVED FIXED
Tracking Status
firefox38 --- unaffected
firefox38.0.5 --- unaffected
firefox39 --- unaffected
firefox40 --- disabled
firefox41 --- disabled
firefox-esr31 --- unaffected

People

(Reporter: KWierso, Unassigned)

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

16:44:57 INFO - nsStringStats
16:44:57 INFO - => mAllocCount: 1178204
16:44:57 INFO - => mReallocCount: 84355
16:44:57 INFO - => mFreeCount: 1178204
16:44:57 INFO - => mShareCount: 3639626
16:44:57 INFO - => mAdoptCount: 92623
16:44:57 INFO - => mAdoptFreeCount: 92623
16:44:57 INFO - => Process ID: 3040, Thread ID: 2816
16:44:57 INFO - TEST-INFO | Main app process: exit status 0
16:44:57 WARNING - TEST-UNEXPECTED-FAIL | browser/devtools/performance/test/browser_perf-columns-memory-calltree.js | leaked 2 window(s) until shutdown [url = http://example.com/browser/browser/devtools/performance/test/doc_simple-test.html]
16:44:57 INFO - TEST-INFO | browser/devtools/performance/test/browser_perf-columns-memory-calltree.js | windows(s) leaked: [pid = 3040] [serial = 87], [pid = 3040] [serial = 85]
16:44:57 INFO - runtests.py | Application ran for: 0:06:56.181000
16:44:57 INFO - zombiecheck | Reading PID log: c:\users\cltbld\appdata\local\temp\tmp0x9ntkpidlog
16:44:57 INFO - Stopping web server
16:44:57 INFO - Stopping web socket server
16:44:57 INFO - Stopping ssltunnel
16:44:57 INFO - TEST-INFO | leakcheck | default process: leak threshold set at 0 bytes
16:44:57 INFO - TEST-INFO | leakcheck | plugin process: leak threshold set at 0 bytes
16:44:57 INFO - TEST-INFO | leakcheck | tab process: leak threshold set at 25000 bytes
16:44:57 INFO - TEST-INFO | leakcheck | geckomediaplugin process: leak threshold set at 20000 bytes
16:44:57 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 3040
16:44:57 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
16:44:57 INFO - | | Per-Inst Leaked| Total Rem|
16:44:57 INFO - 0 |TOTAL | 16 0|148150327 0|
16:44:57 INFO - nsTraceRefcnt::DumpStatistics: 1349 entries
16:44:57 INFO - TEST-PASS | leakcheck | default process: no leaks detected!
16:44:57 INFO - runtests.py | Running tests: end.
16:44:58 INFO - 4478 INFO checking window state
16:44:58 INFO - 4479 INFO TEST-START | Shutdown
16:44:58 INFO - 4480 INFO Browser Chrome Test Summary
16:44:58 INFO - 4481 INFO Passed: 2306
16:44:58 INFO - 4482 INFO Failed: 0
16:44:58 INFO - 4483 INFO Todo: 0
16:44:58 INFO - 4484 INFO *** End BrowserChrome Test Results ***
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Attachment #8600143 - Flags: review?(vporof) → review+
https://hg.mozilla.org/mozilla-central/rev/7b22dbb2e7d6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
Status: RESOLVED → REOPENED
Flags: needinfo?(jsantell)
Resolution: FIXED → ---
Target Milestone: Firefox 40 → ---
This seems to be a separate issue than the `recording is null` one, looks like a straight up leak in tests
Flags: needinfo?(jsantell)
Still looking at this, and it's pretty active -- can you give this a once over to see if anything jumps out at you? Only thing unique about the refresh test is the frame script, but other tests can leak too, so not sure what's the cause of that..
Flags: needinfo?(vporof)
Will do! Keeping the needingfo? so I don't forget.
Have a chance to look at this? This one's out of control.
Blocks: perf-tool-v2
Priority: -- → P1
This disables framerate and memory recording in browser_perf-refresh.js Hopefully this works, and means we can reduce our surface area and figure out where the actual leak is.
Attachment #8603888 - Flags: review?(vporof)
All these intermittents are from other failures, so looks like removing the FPS/memory actors worked . . . so now just gotta figure out which one is leaking.
Flags: needinfo?(vporof)
No longer blocks: perf-tool-v2
Assignee: jsantell → vporof
Status: REOPENED → ASSIGNED
Very low occurrence rate. Still on my radar, but not actively trying to figure out what's wrong.
Status: ASSIGNED → NEW
Assignee: vporof → nobody
Has not happened in 6 months, closing.
Status: NEW → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.