[APZ] Popup arrow panel UI broken if scrollbar in rtl displayed

RESOLVED DUPLICATE of bug 1194851

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 1194851
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

40 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8596344 [details]
screenshot

This was caused by https://hg.mozilla.org/mozilla-central/rev/17aad8f83237
And fixed by backed out https://hg.mozilla.org/mozilla-central/rev/570bb53a3e7b

Steps to Reproduce:
1. Install https://github.com/gorhill/uBlock/releases/download/0.9.4.6-dev.1/uBlock0.firefox.xpi
2. Turn on "I am an advanced user (Required reading)" from option ( chrome://ublock0/content/dashboard.html )
3. Open Youtube Video (e.g. https://www.youtube.com/watch?v=55s3T7VRQSc )
4. Click uBlock0 toolbar button

Actual Results:
1 columun is missing

Expected Results:
3 columns should display
(Reporter)

Comment 1

3 years ago
Regression window if forced to enable APZ (layers.async-pan-zoom.enabled = true):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=24fe1880f83b&tochange=d3b41b0ead7d

Triggered by: d3b41b0ead7d David Anderson — Remove apz.subframe.enabled and assume it is always true. (bug 1128761, r=kats)
Something to check: does this still happen if layers.async-pan-zoom.enabled is false but layout.event-regions.enabled is true?
(Reporter)

Comment 3

3 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> Something to check: does this still happen if layers.async-pan-zoom.enabled
> is false but layout.event-regions.enabled is true?

setting
layers.async-pan-zoom.enabled = false
layout.event-regions.enabled = true (default)
in Nightly40.0a1(2015-04-22 946ac85af8f4)
and restart, then the problem is gone.

Comment 4

3 years ago
Problem no longer reproducible with 20150426 nightly.
Fixed ?
(Reporter)

Comment 5

3 years ago
yes, it was fixed by backed out (https://hg.mozilla.org/mozilla-central/rev/570bb53a3e7b)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Reopening because we'll need to fix this at some point, apz will be on by default soon.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I can reproduce this on Linux using the latest uBlock add-on from github and the rest of the STR in comment 0. Looks like the clip isn't properly accounting for the scrollbar on the left, although I haven't looked at a layer dump to verify that yet.

Updated

3 years ago
Whiteboard: [gfx-noted]

Updated

3 years ago
Blocks: 1013364
Forward-duping since the newer bug has a simple test case attached.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1194851
You need to log in before you can comment on or make changes to this bug.