Status

()

Firefox for iOS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: wesj, Unassigned)

Tracking

unspecified
Other
iOS
Dependency tree / graph

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
Duplicate of this bug: 1157845
Comment on attachment 8596734 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/370

Results in a startup crash...
Attachment #8596734 - Flags: review?(bnicholson) → review-
Note that bug 1157394 just landed, so for whatever fix we end up with here, let's make sure all of our ViewMemoryLeakTests are passing to verify.
Blocks: 1130522
tracking-fennec: --- → ?
Summary: WeakTabManagerDelegate should use weak references → TabManager memory leak

Updated

3 years ago
tracking-fennec: ? → +
Duplicate of this bug: 1158953
(Reporter)

Updated

3 years ago
Blocks: 1158951
(Reporter)

Comment 6

3 years ago
Created attachment 8600112 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/406

Updated to not crash the world.
Attachment #8596734 - Attachment is obsolete: true
Can you confirm all tests pass now with this fix?
(Reporter)

Comment 9

3 years ago
All the tests that pass for me (not all of them), pass after this as well. The about:home ones give me grief with and without this patch. I gave up on fixing that.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.