cairo-gtk3 toolkit build fails with undefined reference to 'gtk_window_set_auto_startup_notification'

RESOLVED FIXED in Firefox 40

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: lsalzman, Assigned: lsalzman)

Tracking

Trunk
mozilla40
Points:
---

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
When building with --enable-default-toolkit=gtk3, the build fails with the following link error for libxul.so:

 0:20.63 /home/lee/central/toolkit/xre/nsAppRunner.cpp:3645: error: undefined reference to 'gtk_window_set_auto_startup_notification'

This is because there is a missing stub defined for this function in the mozgtk shim.
Attachment #8597261 - Flags: review?(nical.bugzilla)
Attachment #8597261 - Flags: review?(nical.bugzilla) → review+
Assignee: nobody → lsalzman
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
The sheriffs will mark the bug RESOLVED FIXED when the bug reaches mozilla-central (at the moment it just landed on mozilla-inbound).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Duplicate of this bug: 1157413

Updated

4 years ago
Blocks: 1155943
Component: General → General
Product: Firefox → Core
Version: unspecified → Trunk

Updated

4 years ago
Duplicate of this bug: 1157869
https://hg.mozilla.org/mozilla-central/rev/23b690bc61fc
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.