[NFC] Swiping up causes jerky, stuttered animation in the Shrinking UI.

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: gduan)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Description:
When swiping up on a piece of content to share via NFC, the content will animate in a very stuttered, jerky fashion

Repro Steps:
1) Update a Flame to 20150424010200
2) Enable NFC on the DUT, as well as on another device
3) Enter the Gallery app and select an image
4) Tap the back of the DUT to the back of the second device to enter the Shrinking UI
5) Slowly swipe up on the image

Actual:
The image card will animate in a jerky, stuttering fashion

Expected:
The image card will animate smoothly.

Environmental Variables:
Device: Flame 3.0 (512MB)(Full Flash)
Build ID: 20150424010200
Gaia: 0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gecko: 22a157f7feb7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 10/10
See attached: Logcat, Video (URL)
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.2, 2.1, and 2.0 builds.
The image card will animate in a jerky, stuttering fashion

Note: The issue seems less severe in 2.1 and 2.0 builds.

Environmental Variables:
Device: Flame 2.2 (512MB)(Full Flash)
Build ID: 20150424002507
Gaia: b838d0e7c163e66660dcb6e387d8339944a7a30e
Gecko: 5fe76b26e55f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 (512MB)(Full Flash)
Build ID: 20150424001201
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 6a68a038146a
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 (512MB)(Full Flash)
Build ID: 20150424000201
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: ff96615f8cfc
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(ashiue)

Comment 3

4 years ago
Do not nominate to block since this is not a functional bug.
Add gaia developers in CC list to aware this issue.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(ashiue)
ni? for Juwei on this.

This is a pretty bad UX, and the similar bugs have been identified as 2.1+. See Bug 997606 and Bug 1033136.
Flags: needinfo?(jhuang)
Hi,
Please do block this bug since it's a very bad experience.
People wouldn't be able to trust this function if it display choppy.
Flags: needinfo?(jhuang)

Comment 6

4 years ago
According to comment 5, nominate this issue.
blocking-b2g: --- → 2.2?
Ni gaia developer and see if he can help to fix the problem.
Flags: needinfo?(gduan)
Assignee: nobody → gduan
Flags: needinfo?(gduan)
triage: will have George's input prior to making blocking decision.
Hi Greg,
I deeply look into the code and found out that we we set timeout to update new position from touchmove event, it might cause the tilting screen doesn't follow user's finger just like this bug. I'm wondering why can't we simply follow the touchmove's movement exactly and transmit the file when the moving distance is over the threshold.
Flags: needinfo?(gweng)
This is to prevent touch event fire too hurriedly and too sharply. If it can go smoother without that, and we can handle issues like queuing them, it's OK to remove the delay.
Flags: needinfo?(gweng)
Hi Martin,
could you check if attachment 8603963 [details] [review]  works for you ? It looks fine on my device. Thanks.
Flags: needinfo?(mshuman)
(Reporter)

Comment 13

4 years ago
This looks fine on my device as well. After checking attachment 8603963 [details] [review], the issue does appear to be fixed and the NFC Shrinking UI is animating smoothly.
Flags: needinfo?(mshuman)
Comment on attachment 8603963 [details] [review]
[gaia] cctuan:1158388 > mozilla-b2g:master

Hi Greg,
since you're the original author of this part, could you review this patch for me?

Basically, I remain transitionDurtion as 0.3s when touchend but remove it while touchmove, and I also remove the setTimeout in touchmove handler.
Attachment #8603963 - Flags: review?(gweng)
Comment on attachment 8603963 [details] [review]
[gaia] cctuan:1158388 > mozilla-b2g:master

Please add comments to explain what are you doing. It's important, since after 3 months we would have no idea what the code is doing without that, and thus workarounds get stockpiling.
Attachment #8603963 - Flags: review?(gweng)
Comment on attachment 8603963 [details] [review]
[gaia] cctuan:1158388 > mozilla-b2g:master

Thanks Greg, comments are added, plz check again, thanks!
Attachment #8603963 - Flags: review?(gweng)
triage: per comment 5. and it's kind of like regression per comment 1.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8603963 [details] [review]
[gaia] cctuan:1158388 > mozilla-b2g:master

OK thanks.
Attachment #8603963 - Flags: review?(gweng) → review+
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Per comment 19, could we just modify the "bug component" to System:window mgmt?
manually land to master:
https://github.com/mozilla-b2g/gaia/commit/acc113371d6846c3f9208e0a7e1d92b093a9e8ff
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8603963 [details] [review]
[gaia] cctuan:1158388 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): It's not a regression for gaia, but it probably be a caused by some gecko's improvement for touchmove event.
[User impact] if declined: User might see the jerky animation like http://youtu.be/BXYi2laQDNg .
[Testing completed]: Yes, unit test and manual test
[Risk to taking this patch] (and alternatives if risky): None.
[String changes made]:
Attachment #8603963 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Keywords: verifyme

Comment 23

4 years ago
Verified on 3.0:
Build ID               20150513160203
Gaia Revision          338f66e6a96491d2f5854b188c6b141ceb690d97
Gaia Date              2015-05-13 14:08:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1fab94ad196c
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150513.193307
Firmware Date          Wed May 13 19:33:19 EDT 2015
Bootloader             L1TC100118D0
Comment on attachment 8603963 [details] [review]
[gaia] cctuan:1158388 > mozilla-b2g:master

Approving and keep "verifyme" for 2.2
Attachment #8603963 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as pass on latest build of Flame v2.2 and Nexus 5 v2.2 by the STR in Comment 0.

Actual results: The image card is animate and smooth in Shrinking UI.
See attachment: verified_v2.2.mp4
Reproduce rate: 0/6


Device: Flame v2.2 build(Pass)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.200807
Firmware Date          Tue May 19 20:08:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2 build (Pass)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150519.195445
Firmware Date          Tue May 19 19:55:01 EDT 2015
Bootloader             HHZ12f

---------------------------------------------
Leaving "verifyme" for v2.0&2.1 uplift & verification.
QA Whiteboard: [QAnalyst-Triage+][COM=NFC] → [QAnalyst-Triage+][COM=NFC][MGSEI-Triage+]

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.