mozalloc_abort(char const* const) downloading 5gb MP4

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: condacum, Unassigned)

Tracking

({crash})

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

112.51 KB, application/gzip
Details
Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

I started downloading from
http://s3.amazonaws.com/videos.vimeo.com/330/296/330296048.mp4?AWSAccessKeyId=AKIAJCX4YKY455TWB7MQ&Expires=1429970625&Signature=QbhNwu4iqlwbYtzQrML2m4J6WEM%3D

then I went to dinner. I was absent. Now I am again at my PC and dont see Firefox, I see this crash report:


Actual results:

https://crash-stats.mozilla.com/report/index/a1fb0e68-3f39-42b3-8972-bd5b52150425

It seems that I am not the one and only with this crash in last 7 days
http://postimg.org/image/sxz7qsj69/


Expected results:

It were better if FF could not crash.
Reporter

Updated

4 years ago
Severity: normal → critical
Reporter

Comment 1

4 years ago
I attach a file generated in the session during the crash, that was absent yesterday.
Reporter

Comment 2

4 years ago
Reporter

Comment 3

4 years ago
I add:
Nome evento problema:	APPCRASH
  Nome applicazione:	plugin-container.exe
  Versione applicazione:	37.0.2.5583
  Timestamp applicazione:	552ef76c
  Nome modulo con errori:	mozalloc.dll
  Versione modulo con errori:	37.0.2.5583
  Timestamp modulo con errori:	552ee9ae
  Codice eccezione:	80000003
  Offset eccezione:	00001aa1
  Versione SO:	6.0.6002.2.2.0.768.3
  ID impostazioni locali:	1040
  Informazioni aggiuntive 1:	a9e5
  Ulteriori informazioni 2:	64d53d48ec5e3560d2ba9cd8fe48996c
  Ulteriori informazioni 3:	8fea
  Ulteriori informazioni 4:	6c2190534633e1920d936d44bc3808d6

Comment 4

4 years ago
The filesize is more than 5 GB for this MP4, I doubt FF is able to open and read such a big video.
Of course, you can download the file directly by "save link as" when right clicking.
Reporter

Comment 5

4 years ago
sorry, but I want to download it only, then I watch it with MPC-HC ;)
the crash happened when downloading, not watching.
I would need at least 3 hours for downloading.
Reporter

Comment 6

4 years ago
yes I simply clicked here:
http://postimg.org/image/4dx5nvgo7/

I guess that FF should be able to downloading this file, saving it on my desktop, without crashing.

Comment 7

4 years ago
I don't know why FF would fail to download this file, of course, I'll not test (3 hours is too long).
Could you try again by just saving it locally?
Reporter

Comment 8

4 years ago
(3 hours, because my line is very very slow, maybe your is faster, also no problems ;)
Locally = save on my desktop, this is exactly what I want.
Now I re-start the downloading.
Reporter

Comment 9

4 years ago
it is being saved, as this morning:
http://postimg.org/image/cfid0kxsh/

I hope with no crash now, we will see what happens ;)
Hi,

Do you still have this problem? If you still have this issue please retest it with Firefox Nightly, download it from here: https://nightly.mozilla.org/
Severity: critical → normal
Flags: needinfo?(condacum)
Reporter

Comment 11

4 years ago
the same issue.
Flags: needinfo?(condacum)

Comment 12

4 years ago
The original link is dead. As we can't reproduce it on our side, it will be difficult to debug and fix something...
I will kindly ask you to do some more steps. 

You need to test on Nightly version.

Please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(condacum)
Reporter

Comment 15

4 years ago
Done all the steps above.

Files very big in size cannot be downloaded.
But now I go a hang instead of a regular crash, like it happens here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1206393
Flags: needinfo?(condacum)
User Agent 	Mozilla/5.0 (Windows NT 6.0; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID 	20151210030212

Hi, 
I have tested this problem again and downloaded a file of 1GB, and everything works. I also saw your bug 1206393 and couldn't reproduce that either. You are testing this problems with Nightly, right?
Flags: needinfo?(condacum)
Reporter

Comment 17

4 years ago
yes,

It were better to try with files larger than 1GB.
Flags: needinfo?(condacum)

Comment 18

4 years ago
I tried with a file of 2.3GB this morning, no crash after 1h30.
Reporter

Comment 19

4 years ago
that is good for you ;)

:(
Component: Untriaged → Canvas: 2D
Product: Firefox → Core
(In reply to Yorgos from comment #19)
> that is good for you ;)
> 
> :(

Are you implying you still see the problem?
Flags: needinfo?(condacum)
Yorgos,

The URL from comment 0 is dead.
Do you have another URL to test?
Severity: normal → critical
Keywords: crash
Summary: mozalloc_abort(char const* const) → mozalloc_abort(char const* const) downloading 5gb MP4
Reporter

Comment 22

2 years ago
I refused to download big files with FF since a lot, due to this issue.
I'm marking this bug as WORKSFORME as bug "mozalloc_abort(char const* const)" crashlog signature didn't appear from a long time (over one year) in Firefox.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(condacum)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.