Editing bookmark's Location and Description in the Properties window doesn't work; bookmark title missing

VERIFIED FIXED in Firefox 40

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Ned Moore, Assigned: mano)

Tracking

({regression})

40 Branch
Firefox 40
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox39 unaffected, firefox40 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150427030207

Steps to reproduce:

Using an E10s or a non-E10s window:
Opening a Bookmark with right-click on Properties and then editing the Location/URL line and clicking Save - fails to the retain the edited change.


Actual results:

The location/URL is not changed/updated as edited


Expected results:

Location/URL should have accepted the edit.

Updated

3 years ago
Component: Untriaged → Bookmarks & History

Comment 1

3 years ago
Additionally,

1. Changes to the Description field aren't saved either.

2. the window title says,
Properties for ""
— the actual bookmark title is missing.


Bug 951651 is the likely suspect.

Last good:
20150423030204 | https://hg.mozilla.org/mozilla-central/rev/0b202671c9e2

First bad:
20150424030204 | https://hg.mozilla.org/mozilla-central/rev/22a157f7feb7

Range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b202671c9e2&tochange=22a157f7feb7
Blocks: 951651
Status: UNCONFIRMED → NEW
status-firefox39: --- → unaffected
status-firefox40: --- → affected
Ever confirmed: true
Keywords: regression
Summary: Editing Bookmark URL with Properties Failure → Editing bookmark's Location and Description in the Properties window doesn't work; bookmark title missing

Updated

3 years ago
Flags: needinfo?(mano)

Comment 2

3 years ago
*Error in Browser Console when the Propriety Dialog pops up :

Use of Mutation Events is deprecated. Use MutationObserver instead. bookmarkProperties.js:316:0

*Error in Browser Console when click [Save] button:

NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getBookmarkURI] PlacesUtils.jsm:3115:0

NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsITransactionManager.doTransaction] PlacesUtils.jsm:1967:0
the forst error is unrelated, was there before as well.

The second error is what matters here. I think all of the filed bugs about bookmarks edit being broken are duplicates of a single bug.
Created attachment 8598470 [details] [diff] [review]
patch.diff
Assignee: nobody → mano
Status: NEW → ASSIGNED
Flags: needinfo?(mano)
Attachment #8598470 - Flags: review?(mak77)
Duplicate of this bug: 1158937
Comment on attachment 8598470 [details] [diff] [review]
patch.diff

Review of attachment 8598470 [details] [diff] [review]:
-----------------------------------------------------------------

As I said in the other bug, please file a bug to add a test.
Attachment #8598470 - Flags: review?(mak77) → review+

Comment 7

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/90989388f197
See Also: → bug 1158553
https://hg.mozilla.org/mozilla-central/rev/90989388f197
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified

Updated

2 years ago
Depends on: 1194945
You need to log in before you can comment on or make changes to this bug.