Closed Bug 1159129 Opened 6 years ago Closed 3 years ago

[FFOS2.0][3rd APK][Note]The "My Notebook" number display error.

Categories

(Firefox OS Graveyard :: Gaia::Notes, defect, P2)

defect

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(3 files)

Created an attachment (id=1254130)
 Note2
 
 DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 Enter the Note, create some notes.
 At the note screen, the note's number display error.
 
  EXPECTED BEHAVIOUR:
 The note's number shoule be display right.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached image Note2
Component: Gaia → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Flags: needinfo?(fan.luo)
Keywords: qawanted
I can repro this bug on latest Woodduck v2.0 and Flame v2.0&2.12&2.2&3.0.

See attachments: verify_v2.0m.MP4 and logcat_0159.txt
Reproduce rate: 5/5

Rpero STR:
1.Install Notes app (v2.2.7) from Marketplace.
2.Open Notes and create some notes.
3.Delete two notes.
4.Tap Menu icon at the left top corner.
**The note's number displays error. --KO

-----------------------------------------------------------------------------------
Device: Woodduck 2.0 build(Affected)
Build ID               20150430050314
Gaia Revision          d4d2a2231e60609fafb64f52c09710ece287ea41
Gaia Date              2015-04-23 02:23:38
Gecko Revision         4f0378c84d79ace84439145c2af2c7f118f8173e
Gecko Version          32.0
Device Name            jrdhz72_w_ff
Firmware(Release)      4.4.2
Firmware(Incremental)  1430341522
Firmware Date          Thu Apr 30 05:05:41 CST 2015

Device: Flame 2.0 build(Affected)
Build ID               20150429000200
Gaia Revision          84898cadf28b1a1fcd03b726cff658de470282f0
Gaia Date              2015-04-03 21:42:36
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b154e9aae020
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.032047
Firmware Date          Wed Apr 29 03:20:58 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 build(Affected)
Build ID               20150429001202
Gaia Revision          9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gaia Date              2015-04-28 19:33:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/38ab00c01159
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.034134
Firmware Date          Wed Apr 29 03:41:46 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 build(Affected)
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.035717
Firmware Date          Wed Apr 29 03:57:29 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Affected)
Build ID               20150429010205
Gaia Revision          6e35b0948c42a4398b8a5916015de167121683a1
Gaia Date              2015-04-28 16:06:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.043837
Firmware Date          Wed Apr 29 04:38:48 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(fan.luo)
Keywords: qawanted
Hi Dylan,
Could you please help to check the issue as you seems to be the owner of this app?
Operator partner would like to pre-install this app but mark this bug as high priority.
Thanks!
blocking-b2g: --- → 2.0M+
Flags: needinfo?(doliver)
Attached video verify_v2.0m.mp4
Update Rpero STR:
1.Install Notes app (v2.2.7) from Marketplace.
2.Open Notes and create some notes.
3.Delete a note,then tap "+" and delete it.
4.Tap Menu icon at the left top corner.
**The note's number displays error. --KO
QA Whiteboard: [MGSEI-Triage+]
Component: Preinstalled B2G Apps → Gaia::Notes
Product: Tech Evangelism → Firefox OS
(In reply to Josh Cheng [:josh] from comment #6)
> Hi Dylan,
> Could you please help to check the issue as you seems to be the owner of
> this app?

Unfortunately we don't have anyone staffed on the Notes app at this time. If the partner has the ability to submit a patch, we can review and push an update to the Marketplace.
Flags: needinfo?(doliver)
Hi Dylan,
Does this app also have Git repository? What is the process if anyone like to provide a patch?
Thanks!
No longer blocks: Woodduck_Blocker
blocking-b2g: 2.0M+ → ---
Flags: needinfo?(doliver)
Yes, the app is on github @ https://github.com/mozilla-b2g/notes

The process for submitting patches is the same as Gaia apps -- attach the pull request to a bugzilla bug and you can flag me for review. I'll find someone on the team to take a look at it. Once it's landed I can package the app and submit to Marketplace.
Flags: needinfo?(doliver)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.