Closed Bug 1160565 Opened 5 years ago Closed 5 years ago

Package FormAutofillStartup.js

Categories

(SeaMonkey :: Installer, defect)

defect
Not set

Tracking

(seamonkey2.35 fixed, seamonkey2.36 fixed, seamonkey2.37 fixed, seamonkey2.38 fixed)

RESOLVED FIXED
seamonkey2.38
Tracking Status
seamonkey2.35 --- fixed
seamonkey2.36 --- fixed
seamonkey2.37 --- fixed
seamonkey2.38 --- fixed

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

User Story

http://hg.mozilla.org/comm-central/rev/3d6076209849          SeaMonkey 2.38
http://hg.mozilla.org/releases/comm-aurora/rev/bdd670ca0d82  SeaMonkey 2.37
http://hg.mozilla.org/releases/comm-beta/rev/885507d2d921    SeaMonkey 2.36
http://hg.mozilla.org/releases/comm-release/rev/4087b73dd4e2 SeaMonkey 2.35

Attachments

(1 file)

Error console spew:

> While creating services from category 'profile-after-change', could not create service for entry 'FormAutofillStartup', contract ID '@mozilla.org/formautofill/startup;1'

We need to package FormAutofillStartup.js which is from Bug 1021172 [1].
See also: http://hg.mozilla.org/mozilla-central/rev/9efe325b6dc0

[1] Bug 1021172 - Electrolysis (e10s) support for requestAutocomplete
'nuf said.
Attachment #8600380 - Flags: review?(iann_bugzilla)
Attachment #8600380 - Flags: review?(iann_bugzilla) → review+
a=me for CLOSED TREE too
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/3d6076209849
Target Milestone: --- → seamonkey2.38
Comment on attachment 8600380 [details] [diff] [review]
Patch v1.0 package it.

[Approval Request Comment]
Regression caused by (bug #): Bug 1021172
User impact if declined: Form autofill on password pages may not work.
Testing completed (on m-c, etc.): packaging fix. Form autofill now works.
Risk to taking this patch (and alternatives if risky): packaging fix.
String changes made by this patch: none.
Attachment #8600380 - Flags: approval-comm-release?
Attachment #8600380 - Flags: approval-comm-beta?
Attachment #8600380 - Flags: approval-comm-aurora?
Attachment #8600380 - Flags: approval-comm-beta?
Attachment #8600380 - Flags: approval-comm-beta+
Attachment #8600380 - Flags: approval-comm-aurora?
Attachment #8600380 - Flags: approval-comm-aurora+
(In reply to Philip Chee from comment #4)
> Comment on attachment 8600380 [details] [diff] [review]
> Patch v1.0 package it.
> 
> [Approval Request Comment]
> Regression caused by (bug #): Bug 1021172
> User impact if declined: Form autofill on password pages may not work.
> Testing completed (on m-c, etc.): packaging fix. Form autofill now works.
> Risk to taking this patch (and alternatives if risky): packaging fix.
> String changes made by this patch: none.

Attachment #8600380 [details] [diff] - Flags: approval-comm-release?
Flags: needinfo?(iann_bugzilla)
Flags: needinfo?(iann_bugzilla)
Attachment #8600380 - Flags: approval-comm-release? → approval-comm-release+
Pushed to comm-release
http://hg.mozilla.org/releases/comm-release/rev/4087b73dd4e2
User Story: (updated)
You need to log in before you can comment on or make changes to this bug.