Find out why ClientTiledLayerBuffer::ValidateTile takes so much longer with e10s

RESOLVED DUPLICATE of bug 1161166

Status

()

RESOLVED DUPLICATE of bug 1161166
4 years ago
4 years ago

People

(Reporter: mconley, Unassigned)

Tracking

(Blocks: 2 bugs, {perf})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

4 years ago
useless-profiles
I've started profiling our tab-switching code, and one thing that immediately jumped out is that ClientTiledLayerBuffer::ValidateTile takes a lot longer with e10s. During a tab switch, that method is called from the content process, and seems to do disk IO on its main thread (I guess as shared memory?), and in the profiles I'm about to link to, takes 82 samples in the e10s case.

In the non-e10s case, ClientTiledLayerBuffer::ValidateTile only takes 2 samples.

My test case for these profiles:

Load a "heavy" page in 4 tabs[1], start the profiler, and then cycle between the tabs.

Here's the profile for the e10s case: https://people.mozilla.org/~bgirard/cleopatra/#report=95421952286d2e555c68d7bf281289cdc0b237c4&filter=[{%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A1771,%22end%22%3A5629},{%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A1819,%22end%22%3A2144}]&selection=0,1694,2,47,48,49,224,320,337,1723

And the profile for the single-process case: https://people.mozilla.org/~bgirard/cleopatra/#report=fb4a7f75f792476e52d9d5c0740094ac39b3c7b4&filter=[{%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A2529,%22end%22%3A5926},{%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A3176,%22end%22%3A3350}]&selection=0,1,2,24,25,26,27,114,115,531



[1]: The heavy page I ended up loading happened to be a profile. https://people.mozilla.org/~bgirard/cleopatra/#report=3251a01112034d2265a464bcec6d929e8eed1fd7&filter=[{%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A1194,%22end%22%3A4609},{%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A1210,%22end%22%3A1559}], specifically.
(Reporter)

Comment 1

4 years ago
useless-profiles
Here's another profile where I saw a spinner when switching to a Wordpress editor tab:

https://people.mozilla.org/~bgirard/cleopatra/#report=e70dadc608b6bcc42f48e96aa6e9fec12f553bd5&filter=%5B%7B%22type%22%3A%22RangeSampleFilter%22,%22start%22%3A2797,%22end%22%3A3814%7D%5D&selection=0,2198,2,61,62,63,80,167,586

Here, I'm spending about 500ms in ValidateTile, which seems like an eternity.
(Reporter)

Comment 2

4 years ago
I failed to have stackwalking enabled, so these profiles are useless.

I'll try to gather some better ones.
(Reporter)

Comment 3

4 years ago
We think we've identified the bug that's causing this slowdown, and filed bug 1161166 for it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1161166
You need to log in before you can comment on or make changes to this bug.