[Status Bar] rocketbar is not shown after swiping down from screenshot preview page

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: hcheng, Assigned: kgrandon)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master wontfix)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

*STR:
1. take a screenshot
2. tap the notification to enter screenshot preview page
3. swipe down to show status bar

*Expected result:
After step 3, the rocketbar is shown on status bar.

*Actual result:
After step 3, the rocketbar is not shown on status bar.

*Test env:
**2.2
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.040203
Firmware Date          Sun May  3 04:02:15 EDT 2015
Bootloader             L1TC000118D0

**master
Build ID               20150503010201
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.050218
Firmware Date          Sun May  3 05:02:30 EDT 2015
Bootloader             L1TC000118D0


**master on N5
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.193743
Firmware Date          Sun May  3 19:38:00 EDT 2015
Bootloader             HHZ12f
This is a regression and function broken. nom 2.2 blocker.
blocking-b2g: --- → 2.2?
Keywords: regression, regressionwindow-wanted
Whiteboard: [systemsfe]
Blocks: 1157630
No longer blocks: 1157630
QA Contact: jmercado
This has been like this since Bug 1043284.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.1
BuildID: 20140725073206
Gaia: dd8d9ad3e6ad7a0ed778353a745eda4cae44fcb4
Gecko: 8dc3c0b11f4d
Version: 34.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken 
Environmental Variables:
Device: Flame 2.1
BuildID: 20140725084705
Gaia: f4174cf2bce6d530a9ef7d2a1c3b4df81d748fde
Gecko: a418eea48be4
Version: 34.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: dd8d9ad3e6ad7a0ed778353a745eda4cae44fcb4
Gecko: a418eea48be4

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: f4174cf2bce6d530a9ef7d2a1c3b4df81d748fde
Gecko: 8dc3c0b11f4d

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/dd8d9ad3e6ad7a0ed778353a745eda4cae44fcb4...f4174cf2bce6d530a9ef7d2a1c3b4df81d748fde
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Etienne, can you take a look at this please? This might have been caused by the work done for bug 1043284.
Blocks: 1043284
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(etienne)
blocking-b2g: 2.2? → 2.2+
Kevin said he will take it.
Assignee: nobody → kgrandon
Created attachment 8605234 [details] [review]
[gaia] KevinGrandon:bug_1160915_default_combined_chrome > mozilla-b2g:master
(Assignee)

Comment 6

3 years ago
Comment on attachment 8605234 [details] [review]
[gaia] KevinGrandon:bug_1160915_default_combined_chrome > mozilla-b2g:master

Alive - could you take a look at this? Activities seem to not have a chrome attribute defined, and it seems our chrome logic on whether or not to use the combined chrome may be wrong. (The combined chrome is the only one that works as the shrunken rocketbar).
Attachment #8605234 - Flags: review?(alive)
Comment on attachment 8605234 [details] [review]
[gaia] KevinGrandon:bug_1160915_default_combined_chrome > mozilla-b2g:master

Looks fine, thanks.
Attachment #8605234 - Flags: review?(alive) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(etienne) → needinfo?(hcheng)
(Assignee)

Updated

3 years ago
Depends on: 1165950
(Assignee)

Comment 9

3 years ago
Backed out for causing bug: 1165950

https://github.com/mozilla-b2g/gaia/commit/1030116046e434e21b6cae6b8f4af1fac10205e0
Status: RESOLVED → REOPENED
status-b2g-master: --- → affected
Flags: needinfo?(kgrandon)
Resolution: FIXED → ---
(Assignee)

Comment 10

3 years ago
I took a look here and I don't think this is a regression - I didn't see this behavior on 2.1. Adding qawanted to do branch checks and verify if it's a regression.

Also it seems pretty late for this patch as it's risky and has already caused regressions. I'm renominating it for blocking with the suggestion that we don't block.
blocking-b2g: 2.2+ → 2.2?
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → ?
Flags: needinfo?(kgrandon)
Keywords: regression → qawanted

Comment 11

3 years ago
Created attachment 8607991 [details]
logcat_1854.txt

This bug has been failed verified on latest Nightly Flame v2.2 and Nexus5 v2.2.
See attachments:logcat_1854.txt and 1854.mp4

Reproduce rate: 5/5
Repro STR:
1. take a screenshot
2. tap the notification to enter screenshot preview page
3. swipe down to show status bar

Actual result:
After step 3, the rocketbar is not shown on status bar.

Device: Flame 2.2 build(Fail)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.200807
Firmware Date          Tue May 19 20:08:18 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 build(Fail)
Build ID               20150519162501
Gaia Revision          63e9eeec3032318f8a240f80b6a184fa4b50b6e1
Gaia Date              2015-05-19 17:52:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/4e078e1364d3
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150519.195445
Firmware Date          Tue May 19 19:55:01 EDT 2015
Bootloader             HHZ12f

Comment 12

3 years ago
Created attachment 8607992 [details]
1854.mp4
Comment hidden (obsolete)
status-b2g-v2.2: ? → affected
blocking-b2g: 2.2? → ---
blocking-b2g: --- → 3.0+
Flags: needinfo?(hcheng)
Kevin, are you still working on this?
Flags: needinfo?(kgrandon)
(Assignee)

Comment 15

3 years ago
I'm going to suggest that we close this as wontfix. The reason being: the screenshot preview page is an activity, we can either choose to show the rocketbar on activity screens or not, but it should be consistent. The last time this landed bug 1165950 was opened due to showing rocketbar inside activities, which is consistent with the fix. We can either hide rocketbar, as it is now, or show it everywhere.

We can change this - but I think that would be more feature work, and not a bug.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
status-b2g-master: affected → wontfix
You need to log in before you can comment on or make changes to this bug.