Closed Bug 1157630 Opened 5 years ago Closed 5 years ago

[Flame][E.me Integration]Status bar will not disappear on screenshot preview page.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S11 (1may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: xiongfuchao, Assigned: gmarty)

References

Details

(Whiteboard: [v2.2-nexus-5-l][systemsfe])

Attachments

(4 files)

Attached video video_0838.mp4
[1.Description]:
[Flame][v2.2 & v3.0][E.me Integration]If user take a screenshot and open notifacation when rocketbar is enabled, status bar will not disappear on screenshot preview page, and it overlaps with screenshot preview title.
Found time:08:38
See attachment:logcat_0838.txt & video_0838.mp4

[2.Testing Steps]: 
1.Open rocket bar.
2.Take a screenshot.
3.Tap notification to open the screenshot.
4.Close rockebar

[3.Expected Result]: 
4.Status bar will disappear automatically.

[4.Actual Result]: 
4.Status bar will not disappear.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040348
Firmware Date          Wed Apr 22 04:03:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Affected):
Build ID               20150422160203
Gaia Revision          9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gaia Date              2015-04-22 17:32:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a9311ec2dd39
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.193515
Firmware Date          Wed Apr 22 19:35:27 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Affected):
Build ID               20150422162503
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/367b3e608cd8
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.195718
Firmware Date          Wed Apr 22 19:57:35 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Affected):
Build ID               20150422010202
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/946ac85af8f4
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.044004
Firmware Date          Wed Apr 22 04:40:22 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached file logcat_0838.txt
Component: Gaia::Everything.me → Gaia::System::Window Mgmt
How about 2.1?
Keywords: qawanted
blocking-b2g: --- → 2.2?
Whiteboard: [v2.2-nexus-5-l] → [v2.2-nexus-5-l][systemsfe]
blocking-b2g: 2.2? → 2.2+
In 2.1 the status bar is always visible during screenshot previews so this bug isn't valid there.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150422095813
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 6a68a038146a
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
status-b2g-v2.1: ? → ---
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Keywords: qawanted
Assignee: nobody → gmarty
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Comment on attachment 8597931 [details] [review]
[gaia] gmarty:Bug-1157630-Status-bar-will-not-disappear-on-screenshot-preview-page > mozilla-b2g:master

Etienne, here's a PR I'd like you to review.
Don' hesitate to ping me when you start reviewing it.
Attachment #8597931 - Flags: review?(etienne)
Comment on attachment 8597931 [details] [review]
[gaia] gmarty:Bug-1157630-Status-bar-will-not-disappear-on-screenshot-preview-page > mozilla-b2g:master

The change is fine (the extra work should probably only happen on stackchanged) but maybe we should also close the rocketbar when we open the activity to view the screenshot.
Attachment #8597931 - Flags: review?(etienne) → review+
Target Milestone: --- → 2.2 S11 (1may)
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
NI myself for following uplifting and verification.
Flags: needinfo?(hcheng)
Comment on attachment 8597931 [details] [review]
[gaia] gmarty:Bug-1157630-Status-bar-will-not-disappear-on-screenshot-preview-page > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Web activity and rocket bar
[User impact] if declined: When a screenshot is opened while the rocket bar is active, the status bar is visible. The screenshot is a fullscreen activity so the status bar icons shouldn't be visible, hence a bad UI.
[Testing completed]: This patch is unit tested, but manual testing is needed.
[Risk to taking this patch] (and alternatives if risky): The patch is really small and unit tested so the overall risk is low.
[String changes made]: None.
Attachment #8597931 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8597931 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue still reproduces on Flame Master and 2.2.

Result: The status bar remains on the screenshot preview.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150501002503
Gaia: 209bf4d6fcb16ea6834b8bd86976c012e5914fe6
Gecko: 79e7065ceefa
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
No longer depends on: 1160915
Flags: needinfo?(hcheng)
Hi Guillaume,
Could you please help to check comment 12 from QA?
It seems the problem still there.
Thanks!
Flags: needinfo?(gmarty)
Josh, we have used bug 1160917 for this bug, and have verified it.
Flags: needinfo?(gmarty)
Per Comment 14,this bug had been verified as pass in bug 1160917,so close this bug.
Status: RESOLVED → VERIFIED
I checked on master and I can see it's fixed. Can you please reverify?
If it's still there, can you post a video so that I can compare with my device?
Flags: needinfo?(hcheng)
@Guillaume, this issue has been verified at bug 1160917. ;)
Flags: needinfo?(hcheng)
You need to log in before you can comment on or make changes to this bug.