Closed Bug 1160917 Opened 5 years ago Closed 5 years ago

[Flame][E.me Integration]Status bar will not disappear on screenshot preview page.

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S12 (15may)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: hcheng, Assigned: apastor)

References

Details

(Whiteboard: [v2.2-nexus-5-l][systemsfe])

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1157630 +++
Since the patch of bug 1157630 does not resolve that issue, clone this bug for following.

[1.Description]:
[Flame][v2.2 & v3.0][E.me Integration]If user take a screenshot and open notifacation when rocketbar is enabled, status bar will not disappear on screenshot preview page, and it overlaps with screenshot preview title.
Found time:08:38
See attachment:logcat_0838.txt & video_0838.mp4

[2.Testing Steps]: 
1.Open rocket bar.
2.Take a screenshot.
3.Tap notification to open the screenshot.
4.Close rockebar

[3.Expected Result]: 
4.Status bar will disappear automatically.

[4.Actual Result]: 
4.Status bar will not disappear.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150422002505
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a87a05e7d0ef
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.040348
Firmware Date          Wed Apr 22 04:03:59 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 version(Affected):
Build ID               20150422160203
Gaia Revision          9d4f756aa35cb7f030a92f3c1f65fb55254ddd1d
Gaia Date              2015-04-22 17:32:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a9311ec2dd39
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150422.193515
Firmware Date          Wed Apr 22 19:35:27 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 version(Affected):
Build ID               20150422162503
Gaia Revision          41a85c5f9db291d4f7c0e94c8416b5115b4ee407
Gaia Date              2015-04-21 17:23:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/367b3e608cd8
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.195718
Firmware Date          Wed Apr 22 19:57:35 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_3.0 version(Affected):
Build ID               20150422010202
Gaia Revision          15134b080b5f406e5aa36f5136c17dafb4e31f64
Gaia Date              2015-04-21 19:52:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/946ac85af8f4
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150422.044004
Firmware Date          Wed Apr 22 04:40:22 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Could you take a look?
blocking-b2g: --- → 2.2?
Flags: needinfo?(gmarty)
Assignee: nobody → apastor
blocking-b2g: 2.2? → 2.2+
Attachment #8600838 - Flags: review?(gmarty)
Attachment #8600838 - Flags: review?(gmarty) → review?(kgrandon)
Comment on attachment 8600838 [details] [review]
[gaia] albertopq:1160917-statusbar-rocketbar > mozilla-b2g:master

Sounds good to me. Thanks!
Attachment #8600838 - Flags: review?(kgrandon) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Albert, could you uplift to 2.2? Thanks.
Flags: needinfo?(gmarty) → needinfo?(apastor)
Per Comment 4,this bug has been landed and fixed on master.


This bug has been verified as pass on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: Status bar will disappear automatically.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/5

------------------------------------------------------------------------------
Device: Flame 3.0 build(Pass)
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.193508
Firmware Date          Wed May  6 19:35:21 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0 build (Pass)
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150506.192419
Firmware Date          Wed May  6 19:24:33 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [MGSEI-Triage+]
Comment on attachment 8600838 [details] [review]
[gaia] albertopq:1160917-statusbar-rocketbar > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: The statusbar on fullscreen activities won't behave correctly (visible when it shouldn't, not draggable...), as it won't be detected as fullscreen.
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Low risk patch in terms of changes made. We just recalculate again the fullscreen classes when opening an activity
[String changes made]: none
Flags: needinfo?(apastor)
Attachment #8600838 - Flags: approval-gaia-v2.2?
Attachment #8600838 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Flags: needinfo?(hcheng)
Ryan, could you help merge the PR to v2.2?
This needs rebasing for v2.2 uplift.
Target Milestone: --- → 2.2 S12 (15may)
Flags: needinfo?(apastor)
Could you help verify 2.2?
Flags: needinfo?(hcheng) → needinfo?(lixia)
Keywords: verifyme
This bug has been verified as pass on latest Nightly build of Flame v2.2 and Nexus 5 v2.2 by the STR in Comment 0.

Actual results: Status bar will disappear automatically,and the "screenshot" view shows normally.
See above attachment: verified_v3.0.mp4
Reproduce rate: 0/6


Device: Flame v2.2 build(Pass)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150514.040500
Firmware Date          Thu May 14 04:05:11 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2 build (Pass)
Build ID               20150514002501
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/47f1ced9f1d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150514.033743
Firmware Date          Thu May 14 03:37:59 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
Flags: needinfo?(lixia)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.