[Browser]The pop up dialog in Browser was not in full screen.

RESOLVED DUPLICATE of bug 1160191

Status

defect
RESOLVED DUPLICATE of bug 1160191
4 years ago
4 years ago

People

(Reporter: wangxin, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l][systemsfe])

Attachments

(3 attachments)

Reporter

Description

4 years ago
[1.Description]:
[Nexus 5][2.2&3.0][Browser]When you long press a picture in Browser, the popup box was not displayed in full screen, so a part of the lower layer can be seen from the bottom of screen.
See compare picture:"0241.png"
See log:"logcat_0241"
See video: "0241.mp4"
Found Time: 02:41

[2.Testing Steps]: 
1. Launch Browser.
2. Go to a website with picture(ex. www.baidu.com).
3. Long press the picture.

[3.Expected Result]: 
3.The popup box should be displayed in full screen.

[4.Actual Result]: 
3.The popup box was not displayed in full screen, and a part of the lower layer can be seen from the bottom of screen.

[5.Reproduction build]: 
N5 v2.2 build(Affected):
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.040229
Firmware Date          Sun May  3 04:02:46 EDT 2015
Bootloader             HHZ12f

Nexus_5 3.0(Affected):
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.193953
Firmware Date          Sun May  3 19:40:11 EDT 2015
Bootloader             HHZ12f

Flame 2.2(Unaffected):
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.040203
Firmware Date          Sun May  3 04:02:15 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Unaffected):
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.193941
Firmware Date          Sun May  3 19:39:52 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Reporter

Comment 1

4 years ago
Reporter

Updated

4 years ago
Reporter

Comment 2

4 years ago
Posted video Bug video: 0241.mp4
Evelyn, can you help out here since this is only reproducible on the N5?

I assume the flame testing was done with SHB enabled?
Flags: needinfo?(wangxin)
Flags: needinfo?(ehung)
Reporter

Comment 4

4 years ago
Hi Gregor,
This bug exists on latest Flame2.2&3.0 if you enable SHB.

Flame 2.2(Affected):
Build ID               20150504002502
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.041436
Firmware Date          Mon May  4 04:14:48 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Affected):
Build ID               20150504160201
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.193019
Firmware Date          Mon May  4 19:30:30 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(wangxin)

Comment 5

4 years ago
Gregor, given that Flame could reproduce this issue with SHB enabled, could you find someone to work on it? Let me know if you still need my help. Thank you.
Flags: needinfo?(ehung) → needinfo?(anygregor)
blocking-b2g: --- → 2.2+
Flags: needinfo?(anygregor)
Whiteboard: [2.2-nexus-5-l] → [2.2-nexus-5-l][systemsfe]
This used to work. Can we get a regression window?
Summary: [Nexus 5][Browser]The pop up dialog in Browser was not in full screen. → [Browser]The pop up dialog in Browser was not in full screen.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160191
You need to log in before you can comment on or make changes to this bug.