[Browser] [SHB] - Browser ... menu is too short when SHB is enabled, allowing partial view of and interaction with underlying web page.

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: etienne)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe], [shb-enabled][spark])

Attachments

(4 attachments)

Reporter

Description

4 years ago
Description:
The menu for browser is too short when the SHB is enabled. This creates a gap between the SHB area and the bottom of the menu that is about the same size as the SHB area (see screenshot). The user will be able to see the web-page they were on when accessing the menu. The user can still interact with this small section of the webpage while the menu is up; they can scroll and select options/buttons/links


Repro Steps:
1) Update a Flame to 20150430010201
2) Enable SHB in Developer Settings
3) Launch Browser and navigate to a web-page
4) Select the menu icon (... in upper left)

Actual:
Menu is too short, interactive gap at bottom

Expected:
No gap


Environmental Variables:
Device: Flame 3.0
Build ID: 20150430010201
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 6/6

See attached: screenshot, logcat
Reporter

Comment 1

4 years ago
This issue does NOT occur on Flame 2.2

Actual Results: Menu goes all the way to the SHB button area; no gap

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150429002501
Gaia: 1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gecko: d38ff4717f39
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing], [systemsfe] → [3.0-Daily-Testing], [systemsfe], [shb-enabled]
Reporter

Comment 2

4 years ago
[Blocking Requested - why for this release]:

Nominating to block on 3.0, Visible regression, poor UX
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: pcheng
blocking-b2g: 3.0? → 3.0+
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20150428090816
Gaia: 09ff6cc617c3f77865c746c6dbdd27caebf2b72b
Gecko: 7dc178cee12f
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Device: Flame
BuildID: 20150428095822
Gaia: 6e35b0948c42a4398b8a5916015de167121683a1
Gecko: 632a55ea8268
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko - issue does NOT repro
Gaia: 09ff6cc617c3f77865c746c6dbdd27caebf2b72b
Gecko: 632a55ea8268

Last Working Gecko First Broken Gaia - issue DOES repro
Gaia: 6e35b0948c42a4398b8a5916015de167121683a1
Gecko: 7dc178cee12f

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/09ff6cc617c3f77865c746c6dbdd27caebf2b72b...6e35b0948c42a4398b8a5916015de167121683a1

Caused by Bug 1155785.

Note that the patch for 1155785 was uplifted to v2.2 yesterday, so I've re-checked v2.2 and it is now affected.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Etienne, can you take a look?
Assignee: nobody → etienne
blocking-b2g: 3.0+ → 2.2+
Blocks: 1155785
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1161830
Whiteboard: [3.0-Daily-Testing], [systemsfe], [shb-enabled] → [3.0-Daily-Testing], [systemsfe], [shb-enabled][spark]
Assignee

Comment 8

4 years ago
Comment on attachment 8602078 [details] [review]
[gaia] etiennesegonzac:bug-1160191 > mozilla-b2g:master

Quick one :)
Attachment #8602078 - Flags: review?(kgrandon)
Comment on attachment 8602078 [details] [review]
[gaia] etiennesegonzac:bug-1160191 > mozilla-b2g:master

Seems fine to me. I'm a bit worried that there may be more cases of this though.
Attachment #8602078 - Flags: review?(kgrandon) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Assignee

Updated

4 years ago
Component: Gaia::Browser → Gaia::System::Window Mgmt
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 12

4 years ago
Comment on attachment 8602078 [details] [review]
[gaia] etiennesegonzac:bug-1160191 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1155785
[User impact] if declined: see Description
[Testing completed]: STR from the bugs + alerts/prompts/confirm with and without the SHB
[Risk to taking this patch] (and alternatives if risky): always feel bad marking a small css change as "low risk" because they never really are, but I'm confident :)
[String changes made]: none
Attachment #8602078 - Flags: approval-gaia-v2.2?
Depends on: 1162656
This issue still reproduces on Flame Master. 

Result: The menu fits to the screen in portrait mode. However, the menu still does not fully fit and shows the browser on right side when the device is set in landscape.

Bug 1162656 is filed for the issue.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150507064907
Gaia: 83b27f522642ea573c57e882657ab5c73d4b07f4
Gecko: 403e3c2380b5
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?][failed-verification]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][failed-verification] → [QAnalyst-Triage+][failed-verification]
Flags: needinfo?(ktucker)
See Also: → 1162671
Duplicate of this bug: 1160947
(In reply to Etienne Segonzac (:etienne) from comment #12)
> Comment on attachment 8602078 [details] [review]
> [gaia] etiennesegonzac:bug-1160191 > mozilla-b2g:master
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): bug 1155785
> [User impact] if declined: see Description
> [Testing completed]: STR from the bugs + alerts/prompts/confirm with and
> without the SHB
> [Risk to taking this patch] (and alternatives if risky): always feel bad
> marking a small css change as "low risk" because they never really are, but
> I'm confident :)
haha, given comment #13, do we still want to land this ;) ?
> [String changes made]: none
Flags: needinfo?(etienne)
Assignee

Comment 16

4 years ago
(In reply to bhavana bajaj [:bajaj] from comment #15)
> (In reply to Etienne Segonzac (:etienne) from comment #12)
> > Comment on attachment 8602078 [details] [review]
> > [gaia] etiennesegonzac:bug-1160191 > mozilla-b2g:master
> > 
> > [Approval Request Comment]
> > [Bug caused by] (feature/regressing bug #): bug 1155785
> > [User impact] if declined: see Description
> > [Testing completed]: STR from the bugs + alerts/prompts/confirm with and
> > without the SHB
> > [Risk to taking this patch] (and alternatives if risky): always feel bad
> > marking a small css change as "low risk" because they never really are, but
> > I'm confident :)
> haha, given comment #13, do we still want to land this ;) ?

Ahah, this patch still makes things better, but it's only fixing the portrait case.
I'll send another patch for bug 1162656, it's easier to manage than follow ups (but we'll need both patches).
Flags: needinfo?(etienne)
(In reply to Etienne Segonzac (:etienne) from comment #16)
> (In reply to bhavana bajaj [:bajaj] from comment #15)
> > (In reply to Etienne Segonzac (:etienne) from comment #12)
> > > Comment on attachment 8602078 [details] [review]
> > > [gaia] etiennesegonzac:bug-1160191 > mozilla-b2g:master
> > > 
> > > [Approval Request Comment]
> > > [Bug caused by] (feature/regressing bug #): bug 1155785
> > > [User impact] if declined: see Description
> > > [Testing completed]: STR from the bugs + alerts/prompts/confirm with and
> > > without the SHB
> > > [Risk to taking this patch] (and alternatives if risky): always feel bad
> > > marking a small css change as "low risk" because they never really are, but
> > > I'm confident :)
> > haha, given comment #13, do we still want to land this ;) ?
> 
> Ahah, this patch still makes things better, but it's only fixing the
> portrait case.
> I'll send another patch for bug 1162656, it's easier to manage than follow
> ups (but we'll need both patches).

alright, sounds good.
Attachment #8602078 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest 3.0 build.  Leaving the verifyme keyword so this can be checked on 2.2 when a build is made that has it.

Actual Results: The ... menus fits the whole screen in landscape and in portrait now.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150512010209
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: 502e1a5e722f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][failed-verification] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This bug has been verified as pass on latest Nightly build of Flame v2.2 by the STR in Comment 0.

Actual results: The "..." menu view fits the whole screen in landscape and in portrait mode.
See attachment: verified_v2.2.png
Reproduce rate: 0/5

Device: Flame v2.2 build(Pass)
Build ID               20150513002507
Gaia Revision          e048df68f6f4853b5826a8816e143d95258149de
Gaia Date              2015-05-12 19:10:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0e6b4aab2b94
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150513.041549
Firmware Date          Wed May 13 04:15:58 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.