Closed Bug 1161418 Opened 9 years ago Closed 9 years ago

[e10s] uBlock Origin addon hits "TypeError: Date.now is not a function"

Categories

(Firefox :: Extension Compatibility, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1171173

People

(Reporter: euthanasia_waltz, Unassigned)

References

Details

(Keywords: addon-compat)

https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/
https://github.com/gorhill/uBlock

console log whenever web page is opened
>TypeError: Date.now is not a function vapi-client.js:36:37
>[Exception... "[JavaScript Error: "Date.now is not a function" {file: "chrome://ublock0/content/js/vapi-client.js" line: 36}]'[JavaScript Error: "Date.now is not a function" {file: "chrome://ublock0/content/js/vapi-client.js" line: 36}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/modules/RemoteAddonsParent.jsm :: ObserverParent.notify :: line 354"  data: yes] RemoteAddonsParent.jsm:356:0

This doesn't occur in non-e10s window.
Blocks: e10s-addons
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: addon-compat
This is caused by bug 1172888 – Preference 'extensions.bootstrappedAddons' not updated properly.
and duplicated with bug 1171173 – After start, Disabling/Enabling uBlock considerably lowers page load times with E10s, it is resolved now.

confirmed with
Firefox 42.0a1 20150708030204
uBlock Origin 0.9.9.3 (since the exception was hidden at frameModule.js#349, I modified it to show exception)
There is no problem.

Closing.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.