Do not spam the user with error messages

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: gerard-majax, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sms-most-wanted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Because of bug 1152730, we will get an alert display for each SMS being in error status. If you are sending multiple messages in a row at a moment network is bad, you will not only end up with several messages in error state, but also with multiple stacked alert display which each need to interact with to be able to trigger resend later.

We maybe should just have at most one of those display for each thread that contains messages in error state.
(Reporter)

Updated

3 years ago
Keywords: dogfood
Hey Jenny,

When I discussed about this with Alexandre, I thought that the current full-screen error dialogs are too intrusive, especially when the error doesn't happen right away.

What we should do instead:
* if we're still in the errored thread and the application is display: show a notice at the top of the screen, using the same style than the MMS conversion (or maybe the "new message notice" that's displayed when we receive a message and the thread is scrolled up, with a button). The user would see the style for the error message too.
* if we're in another thread or in the thread list or the application is hidden or the application is closed: add a real notification (as if we received a message) -- we discussed about this also in the past in bug 933133
* have a "error" mark in the Inbox until the user see the thread (like the "unread" mark, but red) -- not easy until we have a DB in Gaia. But I think this is more a nice to have if we do the 2 previous points.

What do you think?
Flags: needinfo?(jelee)
See Also: → bug 1161519
No longer depends on: 1152730
See Also: → bug 1152730

Comment 2

3 years ago
Hey Julien (sorry for the late reply!)

(In reply to Julien Wajsberg [:julienw] (PTO May 8th -> May 17th) from comment #1)
> Hey Jenny,
> 
> When I discussed about this with Alexandre, I thought that the current
> full-screen error dialogs are too intrusive, especially when the error
> doesn't happen right away.
> 

I agree that the full screen error is unnecessary.   

> What we should do instead:
> * if we're still in the errored thread and the application is display: show
> a notice at the top of the screen, using the same style than the MMS
> conversion (or maybe the "new message notice" that's displayed when we
> receive a message and the thread is scrolled up, with a button). The user
> would see the style for the error message too.

Yup! This is pretty reasonable as the message bubble itself will be entirely red that it's hard to miss.

> * if we're in another thread or in the thread list or the application is
> hidden or the application is closed: add a real notification (as if we
> received a message) -- we discussed about this also in the past in bug 933133

This also makes sense and seems we're ready to do it, but the info showing in the error notification needs further discussion in order to distinguish different error messages. Are we able to show (for example) message preview?  


> * have a "error" mark in the Inbox until the user see the thread (like the
> "unread" mark, but red) -- not easy until we have a DB in Gaia. But I think
> this is more a nice to have if we do the 2 previous points.
> 
We already have the "red dot" indicator in inbox design, it'll be great if we can finally implement it =)

Also, what is the timeline for this change? Is this something the engineer side have resource to do recently? Let me know, thanks!
Flags: needinfo?(jelee)

Comment 3

3 years ago
Created attachment 8605697 [details]
[1.5 Messages] Select Items v1.3.pdf

See spec for the error "red dot" in inbox view ;-)
(Reporter)

Updated

3 years ago
Keywords: dogfood → foxfood
Duplicate of this bug: 1161519
About the 3rd point:

Hey Bevis, I know we discussed about getting the error status for a thread but I can't remember where the discussion happened. Do you know where is the archive for this discussion ?

I think the best is to have a "inError" flag on the thread object. This flag would be set to "true" as soon as a message is in error in this thread. Then Gaia could call "setErrorStatus(threadId, true/false)" to set this flag. Gaia would call this if a message is in error but the user is in the thread (so can see it), or when the user enters the thread (kind of like the unread status).

What do you think ?

Eventually we'll have the DB in Gaia with the v2 API but I don't see this happening really soon :/
Flags: needinfo?(btseng)
(Reporter)

Comment 6

3 years ago
Just a note regarding how this should be considered: with bug 1152730 being fixed, I'm much much much less interrupted, so it's much less important IMHO now.
(In reply to Julien Wajsberg [:julienw] from comment #5)
> About the 3rd point:
> 
> Hey Bevis, I know we discussed about getting the error status for a thread
> but I can't remember where the discussion happened. Do you know where is the
> archive for this discussion ?
> 
> I think the best is to have a "inError" flag on the thread object. This flag
> would be set to "true" as soon as a message is in error in this thread. Then
> Gaia could call "setErrorStatus(threadId, true/false)" to set this flag.
> Gaia would call this if a message is in error but the user is in the thread
> (so can see it), or when the user enters the thread (kind of like the unread
> status).
> 
> What do you think ?
> 
> Eventually we'll have the DB in Gaia with the v2 API but I don't see this
> happening really soon :/

I guess you are talking about bug 1101434.
Flags: needinfo?(btseng)
Right, thanks a lot.
Adjusting dependencies.

In this bug, I'd like that we focus on 1st and 2nd points from comment 1; the 3rd point is bug 1090026 and needs the gecko work from bug 1101434. I think 1st and 2nd points can be done right now.
Depends on: 1090026
Whiteboard: [sms-most-wanted]
(In reply to Alexandre LISSY :gerard-majax from comment #6)
> Just a note regarding how this should be considered: with bug 1152730 being
> fixed, I'm much much much less interrupted, so it's much less important IMHO
> now.

You're less interrupted but you still don't know when there is an error if you don't stay on the thread or lock your phone.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.