Closed Bug 1161823 Opened 6 years ago Closed 6 years ago

Comprehensive update to ICANN IDN ccTLD Section as of 2015-05-05 (rolls up 1161789 and 1161790 + more)

Categories

(Core :: Networking: Domain Lists, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: jothan, Assigned: gerv)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached file Comprehensive_IDN_ccTLD_Patch.txt (obsolete) —
This replaces Bug #1161789 and Bug #1161790, and includes additional IDN ccTLDs as one single bug.

Attached is replacement of the WHOLE IDN ccTLD section that nests between .YE and .XXX (with lines for synching in Diff), caught up to include variants, and any IDN ccTLDs introduced as of May 5, 2015 and listed on ICANN's "IDN ccTLD Fast Track String Evaluation Completion" web page.

URL: 
https://www.icann.org/resources/pages/string-evaluation-completion-2014-02-19-en 

Description:
Erik Vanderpoel had reported Belarus and Macedona's IDN ccTLDs missing from the PSL, which caused me to review the ICANN IDN Fast Track listing and identify a number of missing entries to be added.

Summary of Changes:
A modification of the header instructions to include the [variant] label in the per entry comment.

IDN ccTLDs for the following countries are added:
 Armenia 
 Belarus
 Greece
 Iraq
 Macau
 Pakistan
 Sudan

IDN entry for Singapore was moved to conform with the alphabetic ordering by ISO3166 Code.

Due to a constraint of my software, I am unable to generate a DIFF patch, so I submit this as UTF8 text file.

I humbly request that you please make a DIFF patch, and then subsequently patch the PSL with this update to include the revised section.

Thank you
Jothan
Duplicate of this bug: 1161789
Duplicate of this bug: 1161790
Attached patch Patch v.1Splinter Review
This includes the new entries, and also changes the list format to be a bit more sane and sensible.

Gerv
Assignee: nobody → gerv
Attachment #8601802 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Note: this caused a regression, details of which are in bug 1162084, so two entries (those for Pakistan) had to be backed out.

Gerv
https://hg.mozilla.org/mozilla-central/rev/d54fd25feb16
https://hg.mozilla.org/mozilla-central/rev/05c942c83548
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.