Enable Pocket by default (in supported locales)

VERIFIED FIXED in Firefox 38.0.5

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Dolske, Assigned: Dolske)

Tracking

(Depends on 1 bug)

unspecified
Firefox 40
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38 unaffected, firefox38.0.5 verified, firefox39 verified, firefox40 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
Posted patch Patch v.1Splinter Review
Enable Pocket by default in the locales that support it (currently just en-US, as controlled by the browser.pocket.useLocaleList and .enabledLocales prefs)
Attachment #8601866 - Flags: review?(gavin.sharp)
Attachment #8601866 - Flags: review?(gavin.sharp) → review+
Assignee

Updated

4 years ago
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: qe-verify?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Assignee

Comment 3

4 years ago
Comment on attachment 8601866 [details] [diff] [review]
Patch v.1

Approval Request Comment
[Feature/regressing bug #]: n/a
[User impact if declined]: My management will hire hitmen and kill us all.
[Describe test coverage new/current, TreeHerder]: none! But has been manually tested and did a Try run to ensure it doesn't break anything else.
[Risks and why]: Hard to say, but is unlikely to affect users who don't use it, and we have no major known bugs.
[String/UUID change made/needed]: None.
Attachment #8601866 - Flags: approval-mozilla-release?
Attachment #8601866 - Flags: approval-mozilla-aurora?
Flags: qe-verify? → qe-verify+
QA Contact: andrei.vaida
Attachment #8601866 - Flags: approval-mozilla-release?
Attachment #8601866 - Flags: approval-mozilla-release+
Attachment #8601866 - Flags: approval-mozilla-aurora?
Attachment #8601866 - Flags: approval-mozilla-aurora+

Comment 5

4 years ago
Egh, I accidentally still pushed this to fx-team as well, as this seems to not have been merged around yet. :-(
And a followup because I somehow pushed a merge conflict despite clearly resolving it locally before pushing...

https://hg.mozilla.org/releases/mozilla-aurora/rev/a3c2c1c0ebab
Assignee

Updated

4 years ago
Depends on: 1163231
Assignee

Comment 9

4 years ago
Temporary backout on Aurora, so that we can get other stuff uplifted.

https://hg.mozilla.org/releases/mozilla-aurora/rev/43ebc7c3dfcb

Bug 1163231 describes the test failures that need to be fixed. Technically this is caused by bug 1155521 actually adding the Pocket button to the toolbar when enabled, but it's easier to keep up with the uplifts by just temporarily disabling Pocket with a pref flip. Hopefully we can get tests working and Pocket re-enabled in a few days.
Verified Firefox 38.0.5 beta 1 en-US and locales (fr, ml, es-ES, ja, de) builds under Win 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.
For all builds, the following prefs have the same value:
browser.pocket.useLocaleList - true
browser.pocket.enabledLocales - en-US
browser.pocket.enabled - true

The only difference is that the Pocket icon is not available on locales builds, so it can't be used there while the en-US build has the icon on the toolbar.

Is there anything else I should verify for this? Thanks
Flags: needinfo?(dolske)
Assignee

Comment 12

4 years ago
Nope, enabling the Pocket locales is bug 1163645, which unfortunately missed the beta1 uplift.
Flags: needinfo?(dolske)
Assignee

Comment 13

4 years ago
(In reply to Justin Dolske [:Dolske] from comment #9)
> Temporary backout on Aurora, so that we can get other stuff uplifted.
> 
> https://hg.mozilla.org/releases/mozilla-aurora/rev/43ebc7c3dfcb
> 
> Bug 1163231 describes the test failures that need to be fixed. Technically
> this is caused by bug 1155521 actually adding the Pocket button to the
> toolbar when enabled, but it's easier to keep up with the uplifts by just
> temporarily disabling Pocket with a pref flip. Hopefully we can get tests
> working and Pocket re-enabled in a few days.

Now that today's merge-day uplift has completed, I've re-disabled Pocket on the new Aurora (FF40), and enabled it on the new Beta (FF39). Pocket remains enabled on Nightly (FF40) and for the impending 38.0.5 release.

https://hg.mozilla.org/releases/mozilla-aurora/rev/d9093db18dc6
https://hg.mozilla.org/releases/mozilla-beta/rev/f75252949669
Verification on 38.0.5 should suffice here.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Verified that de, es-ES, ja and ru locales have Pocket enabled by default in Firefox 39 beta 1 under all platforms.
No Pocket icon for other locales.
You need to log in before you can comment on or make changes to this bug.