Exit from DOM fullscreen to fullscreen mode cause toolbar automatically collapse on OS X

VERIFIED FIXED in Firefox 40

Status

()

Firefox
General
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: xidorn, Assigned: xidorn)

Tracking

unspecified
Firefox 41
x86_64
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38 unaffected, firefox38.0.5 unaffected, firefox39 unaffected, firefox40 verified, firefox41 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The fullscreen mode on OS X >= 10.7 normally does not hide the toolbar. But after bug 947854, there is a regression that when returning from DOM fullscreen to fullscreen mode, the toolbar will automatically hide.

I'll look into it this weekend. It should be fixed in Firefox 40 anyway. I don't want it to become a regression.
(Assignee)

Comment 1

3 years ago
Created attachment 8603628 [details] [diff] [review]
patch
Attachment #8603628 - Flags: review?(dao)
(Assignee)

Updated

3 years ago
status-firefox38: --- → unaffected
status-firefox38.0.5: --- → unaffected
status-firefox39: --- → unaffected
status-firefox40: --- → affected
status-firefox41: --- → affected

Updated

3 years ago
Attachment #8603628 - Flags: review?(dao) → review+
(Assignee)

Comment 3

3 years ago
Comment on attachment 8603628 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 947854
[User impact if declined]: on OS X >= 10.7, the toolbar will be unexpectedly hidden when exit from DOM fullscreen to fullscreen mode
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: pretty low risk since the code changed affects only Mac, and the logic here looks simple
[String/UUID change made/needed]: n/a
Attachment #8603628 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d11b9d29d909
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
(Assignee)

Updated

3 years ago
Depends on: 1165570
Comment on attachment 8603628 [details] [diff] [review]
patch

Recent regression, taking it.
Attachment #8603628 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

3 years ago
Depends on: 1168397
Verified as fixed using Firefox 40 beta 2 and latest Aurora 41.0a2 2015-07-08 under Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified
status-firefox41: fixed → verified
You need to log in before you can comment on or make changes to this bug.