Closed Bug 1165570 Opened 5 years ago Closed 5 years ago

Native fullscreen button is still displayed even in fullscreen mode on toolbar

Categories

(Firefox :: General, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 41
Tracking Status
firefox40 --- fixed
firefox41 --- fixed

People

(Reporter: xidorn, Assigned: xidorn)

References

Details

Attachments

(1 file, 1 obsolete file)

On Mac OS X, after entering fullscreen mode, the fullscreen button is still displayed on the toolbar. It should be hidden since the system provides such button for exiting on the top menu bar.

This is a regression from bug 1162752.
Assignee: nobody → quanxunzhen
Attached patch patchSplinter Review
Attachment #8606774 - Flags: review?(dao)
Attached patch patch (obsolete) — Splinter Review
Attachment #8606774 - Attachment is obsolete: true
Attachment #8606774 - Flags: review?(dao)
Attachment #8607845 - Flags: review?(dao)
Comment on attachment 8607845 [details] [diff] [review]
patch

>+    // For Lion fullscreen, all fullscreen controls are hidden, don't
>+    // bother to touch them. If we don't stop here, the following code
>+    // could cause the native fullscreen button be shown unexpectedly.
>+    // See bug 1165570.
>+    if (!aShow && this.useLionFullScreen) {
>+      return;
>+    }

Why do you care about !aShow here?
I guess it doesn't really matter... When I was debugging bug 1105939, I suspected a bug was potentially related to this, which later was proven to be false. Hence it seems to me that either version is fine. If you think the old one is better, you could obsolete the new one and grant the old one :)
Attachment #8606774 - Attachment is obsolete: false
Attachment #8606774 - Flags: review+
Attachment #8607845 - Attachment is obsolete: true
Attachment #8607845 - Flags: review?(dao)
https://hg.mozilla.org/mozilla-central/rev/1bc7f9b2e95c
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Duplicate of this bug: 1166973
Comment on attachment 8606774 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1162752
[User impact if declined]: will see fullscreen button on tabbar even in fullscreen mode
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: shouldn't be risky
[String/UUID change made/needed]: n/a
Attachment #8606774 - Flags: approval-mozilla-aurora?
Attachment #8606774 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.