Closed Bug 1162769 Opened 7 years ago Closed 7 years ago

[Contacts] Importing contacts from Gmail or Outlook will display an 'Imported # contacts' with # = to the # of contacts from most previous SIM contact import

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
2.2 S14 (12june)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: jmitchell, Assigned: arcturus)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Description:
In contacts app, importing from outlook or gmail will not show the correct # of contacts imported. Instead, it will show the # of contacts from the most previous SIM contact import function. 
Example) Importing 35 contacts from SIM 2 and then importing 6 contacts from outlook will result in a notification of '35 contacts imported' instead of '6 contacts imported' 
If you then import 8 contacts from SIM 1, 8 will show for the next gmail / outlook import.


Repro Steps:
1) Update a Flame to 20150507064907
2) Launch Contacts > Settings > Import Contacts
3) Import contacts from a SIM card (take note of # of contacts imported)
4) Import contacts from gmail or outlook (not the same # from prior step)


Actual:
# of contacts imported message shown is from SIM contact imported

Expected:
# of contacts imported message shown is from gmail / outlook import


Environmental Variables:
Device: Flame 3.0
Build ID: 20150507064907
Gaia: 83b27f522642ea573c57e882657ab5c73d4b07f4
Gecko: 403e3c2380b5
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 7/7
See attached: logcat, video clip: http://youtu.be/CO1r1qNLhZE
Issue does not occur in Flame KK 2.2

Actual Result: contact imported # shows the correct #

Device: Flame 2.2 (KK - Nidghtly - Full Flash - 319mem)
Build ID: 20150508002501
Gaia: 88d3ac2721a5484495c2ed60e4a068945f0de5aa
Gecko: 8ad16ebe659d
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
[Blocking Requested - why for this release]: Regression.
blocking-b2g: --- → 3.0?
Regression that is blocking release, as stated in comment 2. Requesting a window
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
QA Contact: bzumwalt
B2G-Inbound Regression Window:

Last working B2G-Inbound build:
Device: Flame 3.0
Build ID: 20150410033337
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: b99b34dc9bd4
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First broken B2G-Inbound build:
Device:  Flame 3.0
BuildID: 20150410044437
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: 5a1b56e833f0
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 749b6eb12c103f4119f1f85c72dbe7791684d8dc
Gecko: 5a1b56e833f0

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: 6e403dbb863fb9ec41bd22b6583e2eff5045d78b
Gecko: b99b34dc9bd4


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/749b6eb12c103f4119f1f85c72dbe7791684d8dc...6e403dbb863fb9ec41bd22b6583e2eff5045d78b


Issue appears to occur due to changes made in bug 1066347
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Zibi, can you take a look at this please? This might have been caused by the landing for bug 1066347.
Blocks: 1066347
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(gandalf)
Seems to be the same problem as bug 1162758 based on the log.
Flags: needinfo?(gandalf)
[Blocking Requested - why for this release]: Regression which impacts the first time experience.
blocking-b2g: 3.0? → spark?
blocking-b2g: spark? → spark+
Hi,

if you are interested in fixing this please take a look to the following files:


https://github.com/mozilla-b2g/gaia/blob/master/shared/js/contacts/import/contacts_importer.js#L184
That's the function that display the message.

https://github.com/mozilla-b2g/gaia/blob/master/shared/js/contacts/import/contacts_importer.js#L18
That's the counter for the number of contacts imported, probably we are not reseting the process.

Hope this helps!
Assignee: nobody → mr.reception
Flags: needinfo?(mr.reception)
I will steal this bug since it's spark+ and we will need to get fix soon
Assignee: mr.reception → francisco
Attached file wip
Comment on attachment 8617531 [details] [review]
wip

Fer can you take a quick look?
Attachment #8617531 - Flags: review?(ferjmoreno)
Attachment #8617531 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/d63847b857c0626e266a60dccfa4532f5b809f25
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: After imported contacts from SIM card, the number ("#") of contacts imported from gmail/ outlook always shows correctly.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/15

Device: Flame v3.0 build(Pass)
Build ID               20150611160204
Gaia Revision          68269e7b6510930eb2f644f69d27d456c1bdec75
Gaia Date              2015-06-10 23:36:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ebd530c5843
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150611.193436
Firmware Date          Thu Jun 11 19:34:48 EDT 2015
Bootloader             L1TC000118D0


Device: Nexus 5 v3.0 build(Pass)
Build ID               20150611160204
Gaia Revision          68269e7b6510930eb2f644f69d27d456c1bdec75
Gaia Date              2015-06-10 23:36:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9ebd530c5843
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150611.192554
Firmware Date          Thu Jun 11 19:26:10 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
blocking-b2g: spark+ → 2.5+
Target Milestone: --- → 2.2 S14 (12june)
Flags: needinfo?(mr.reception)
You need to log in before you can comment on or make changes to this bug.