Several test failures in testSessionStore/testUndoTab.js

RESOLVED INVALID

Status

Mozilla QA
Mozmill Tests
P1
normal
RESOLVED INVALID
3 years ago
a year ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(firefox40 disabled)

Details

(Whiteboard: [mozmill-test-failure][mozmill-test-skipped])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
This is a recent regression for the testSessionStore/testUndoTab.js test module which started May 6th. A Nightly from May 5th works like expected.

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4c93d46ab92f&tochange=60349cbc3d4e

Failures:

  "fail": {
    "message": "'Undo Close Tab' is disabled - got 'false'", 
    "fileName": "file:///mozilla/code/mozmill-tests/nightly/firefox/tests/functional/testSessionStore/testUndoTab.js", 
    "name": "testUndoTabFromContextMenu", 
    "lineNumber": 49
  }


    "message": "'Recently Closed Tabs' sub menu has to be empty - '2' should equal '0'", 
    "lineNumber": 54, 
    "name": "Error", 
    "fileName": "file:///mozilla/code/mozmill-tests/nightly/firefox/tests/functional/testSessionStore/testUndoTab.js"


    "message": "'Recently Closed Tabs' sub menu entries have changed - '3' should equal '2'", 
    "lineNumber": 855, 
    "name": "Error", 
    "fileName": "file:///mozilla/code/mozmill-tests/nightly/firefox/lib/tabs.js"
(Reporter)

Updated

3 years ago
Priority: -- → P1
(Reporter)

Comment 1

3 years ago
Created attachment 8603193 [details] [diff] [review]
skip patch

For now lets skip this test.
Comment hidden (obsolete)
(Reporter)

Comment 4

3 years ago
Tim, do you have any idea if your patch on bug 1160556 could have caused this different behavior? Otherwise I cannot find anything else related to sessionstore in the pushlog.
Flags: needinfo?(ttaubert)
(Reporter)

Updated

3 years ago
status-firefox40: --- → disabled
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
That's more likely caused by bug 1109875 that made state collection for closing tabs asynchronous. This shouldn't really matter in normal usage but would probably break a few tests that close a tab and in the same tick expect all state to be saved and "undo-closeable".
Flags: needinfo?(ttaubert)
(Reporter)

Comment 6

3 years ago
Indeed, that sounds like it is the problem here. Thanks Tim! Given the amount of work I would have to put in here, I will keep this test skipped. Once we convert the sessionstore tests to Firefox UI Tests, we will pick up this information and handle the event properly.
Blocks: 1109875
Keywords: regressionwindow-wanted
(Reporter)

Comment 7

a year ago
Mozmill tests have been superseded by Marionette tests.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.