Closed Bug 1163066 Opened 7 years ago Closed 7 years ago

Autophone - 2015-05-07 regression in Throbber stop Second Run on mozilla-inbound

Categories

(Firefox for Android Graveyard :: General, defect)

40 Branch
defect
Not set
normal

Tracking

(firefox40 affected, fennec40+)

RESOLVED FIXED
Tracking Status
firefox40 --- affected
fennec 40+ ---

People

(Reporter: bc, Assigned: n.nethercote)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/norejected/2015-05-07/2015-05-07/cached/errorbars/standarderror/notry

It is most apparent on local blank; nexus 4/android 4.2; nexus 7/android 4.3 and to some extent on nexus 5/android 4.4. I think these are all multiple core machines. It does not appear on the nexus s/Android 2.3 single core machine. local twitter is too noisy

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fa8214db7c82&tochange=c375efe78e07

Looks like Bug 1161377
Blocks: 1161377
> Looks like Bug 1161377

Part 1 in that bug unintentionally added five new static constructors, which is very likely the cause. I just landed part 2.5 which removes them again. Hopefully that'll fix things.
njn: looking at the graph, nexus 4 and 5 have a slight regression around there. nexus 7 is lagging so it hasn't gotten to that changeset yet.

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8d4411ad492b&tochange=a0587959d25e
Also, the original regression range shows a regression in the throbber start first run time for the nexus 5 Android 4.4 devices as well.

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstart/local-blank/rejected/2015-05-06/2015-05-13/notcached/noerrorbars/standarderror/notry
(In reply to Bob Clary [:bc:] from comment #2)
> njn: looking at the graph, nexus 4 and 5 have a slight regression around
> there. nexus 7 is lagging so it hasn't gotten to that changeset yet.

The Nexus 7 has caught up now and is also showing a regression.

So, I inadvertently introduced five new static constructors and caused a slowdown. And then I removed them and made things even worse. I don't understand.

I guess I could back out all four patches from bug 1161377. That's frustrating, because I have another 10 follow-up patches in my queue that require part 1. I'll do a try run with the four patches backed out, see what that does.
> I'll do a try run with the four patches backed out, see what that does.

Results are here:
http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/norejected/2015-05-12/2015-05-13/cached/errorbars/standarderror/try

There are two runs, one with the current trunk, and one with the four patches form bug 1161377 backed out.

It looks to me like the improvement caused by the backout is significantly less than the combination of the two regressions.
I did another two try pushes, one of the revision just before I landed my patches, and then that one plus my patches. (So this avoids the other regressions that have happened over the past few days.)

http://phonedash.mozilla.org/#/org.mozilla.fennec/throbberstop/local-blank/norejected/2015-05-12/2015-05-13/cached/errorbars/standarderror/try

Nexus 4 and 7 show regressions, Nexus 6 is unchanged, Nexus 5 hasn't come in yet. Sigh.
(In reply to Nicholas Nethercote [:njn] from comment #6)

> 
> Nexus 4 and 7 show regressions, Nexus 6 is unchanged, Nexus 5 hasn't come in
> yet. Sigh.

the nexus-5-kot49h-4 device has discharged and shut down. See Bug 1164871.

you mean nexus s instead of nexus 6, right?
Depends on: 1164871
Assignee: nobody → n.nethercote
tracking-fennec: ? → 40+
> you mean nexus s instead of nexus 6, right?

"nexus-s-6", whatever that is :)
I ended up backing out all the patches in bug 1161377.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.