Closed Bug 1163120 Opened 5 years ago Closed 5 years ago

Restore tabs lazy

Categories

(Firefox for iOS :: General, defect)

Other
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: st3fan, Assigned: wesj)

References

Details

Attachments

(1 file)

Suggestion to shave off 100s of ms

When we restore your tabs, we ask the TabManager to create new tabs with a specific NSURL. This immediately creates a WKWebView instance. This is an extremely expensive operation. The more tabs people have open, the worse this gets. We should only fully restore the front tab. And restore the others lazily when they are opened.
Assignee: nobody → wjohnston
tracking-fennec: ? → +
Attachment #8609192 - Flags: review?(bnicholson)
Hey Wes,

I wonder if this could also fix this issue? https://bugzilla.mozilla.org/show_bug.cgi?id=1163122
Not as is, but it might help. The tricky part there is that we actually need to load a "blank" url in the tab in order to have about:home in the back-stack.
Updated this to not support zombifying anymore.
Comment on attachment 8609192 [details] [review]
PR https://github.com/mozilla/firefox-ios/pull/492

Nice, this looks good to me, though you'll have to do a bit more rebasing after #521 (sorry). That PR adds a testWebViewDisposed to make sure the webview gets disposed when the browser is removed, so it'd be good to make sure that still passes with this (especially considering you moved some deregistration into the Browser deinit).
Attachment #8609192 - Flags: review?(bnicholson) → review+
Depends on: 1169836
https://github.com/mozilla/firefox-ios/commit/b5861146d45a1f5b913b56401a35eed00104afaf
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Depends on: 1169833
No longer depends on: 1169833
I'm reopening this bug because it broke opening reading list items.

STR:

1) Add item to your reading list
2) Open item from the reading list panel

The app crashes because browser.webView is nil.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Filed 1170906 for this. I'll track it there.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1097402
You need to log in before you can comment on or make changes to this bug.