libvdpau_nvidia.so.340.76 crash on video seek in Firefox 37 on Linux

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: rickardnorlander, Unassigned)

Tracking

({crash})

37 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150417180400

Steps to reproduce:

Ubuntu 15.04, Firefox 37.0.2

1. $ firefox -p. create new profile, sign in with it
2. about:addons, disable all plugins and extensions
3. Start a youtube clip
4. Try to seek in the clip


Actual results:

Firefox crashes


Expected results:

Seeking should work
Flags: needinfo?(rickardnorlander)
Component: Untriaged → Video/Audio
Product: Firefox → Core
(Reporter)

Comment 2

4 years ago
Here is the crash

https://crash-stats.mozilla.com/report/index/ae442447-00a0-46f4-8424-1e4c02150509
Flags: needinfo?(rickardnorlander)

Comment 3

4 years ago
Based on the crash report, it looks like your video drivers are what's actually crashing here.

bp-ae442447-00a0-46f4-8424-1e4c02150509
0   libc-2.21.so                libc-2.21.so@0x14d9a6
1   libX11.so.6.3.0             libX11.so.6.3.0@0x3cac6
2   libvdpau_nvidia.so.340.76   libvdpau_nvidia.so.340.76@0x87b81
3   libvdpau_nvidia.so.340.76   libvdpau_nvidia.so.340.76@0xab90

App Notes:
OpenGL: NVIDIA Corporation -- GeForce GTX 780/PCIe/SSE2 -- 4.4.0 NVIDIA 340.76 -- texture_from_pixmap
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: Firefox crashes on video seek → libvdpau_nvidia.so.340.76 crash on video seek in Firefox 37 on Linux

Comment 4

4 years ago
Standard advice is of course to update your video drivers, if available to do so.
(Reporter)

Comment 5

4 years ago
Updating my video drivers to 346.59 did not solve the problem. If anyone else has this problem btw, a workaround is to enable flash.
Component: Audio/Video → Audio/Video: Playback
(Reporter)

Comment 6

3 years ago
I believe the crash was caused by a faulty gstreamer installation/config. Can be closed or downgraded from P3 as far as I am concerned.
Did the crash go away after you updated GStreamer? We have seen quite a few crashes due to GStreamer bugs.
Keywords: crash
Priority: -- → P5
gstreamer is going in bug 1234092
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.