Closed Bug 1163326 Opened 6 years ago Closed 6 years ago

implement dirty select tracking in bug-modal to address firefox refresh issue

Categories

(bugzilla.mozilla.org :: User Interface, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Fallen, Unassigned)

References

Details

Attachments

(1 file)

So I am not totally sure if this is an issue with the new UI, but I don't often run into situations where I make bug changes without knowing about it and I've just been test driving the new UI.

In bug 1154521 comment 22 I made some changes to tracking flags I wasn't aware of. I had this tab open for a while, reloaded the page to get the latest changes, then made my comment and set needinfo. The tracking flags were reset to their previous state.

If there is no good way to track this down feel free to RESO INCOMPLETE, if you can and its really a bug that can be fixed even better :)
looks like i forgot about bug 437212.
Assignee: nobody → glob
Blocks: 1150541
Summary: Tracking flags are updated without interaction → implement dirty select tracking in bug-modal to address firefox refresh issue
Attached patch 1163326_1.patch β€” β€” Splinter Review
- implement dirty field tracking

see https://bugzilla.mozilla.org/show_bug.cgi?id=437212#c28 for steps-to-reproduce, except test using a tracking flag.
Attachment #8604122 - Flags: review?(dylan)
Comment on attachment 8604122 [details] [diff] [review]
1163326_1.patch

Review of attachment 8604122 [details] [diff] [review]:
-----------------------------------------------------------------

r=dylan

Tested -- dirty tracking flags keep their value (unless they've been changed by another user first, I assume that's intentional).

I used firefox on two different machines to confirm, I was not able to use chrome to test this. I actually am not certain tracking flags can even be set in chrome. No errors in the dev console, just silently failed. Weird, eh?
Attachment #8604122 - Flags: review?(dylan) → review+
(In reply to Dylan William Hardison [:dylan] from comment #3)
> I actually am not certain tracking flags can even be
> set in chrome. No errors in the dev console, just silently failed. Weird, eh?

filed bug 1164321 for the chrome issue.


To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   53af86d..0622523  master -> master
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: glob → nobody
Component: User Interface: Modal → User Interface
You need to log in before you can comment on or make changes to this bug.