ReaderParent.jsm:95:12 throws an error in the Browser Console when clicking the "Enter Reader View" button from the Location Bar

VERIFIED FIXED in Firefox 38.0.5

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: avaida, Assigned: jaws)

Tracking

38 Branch
mozilla38
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38.0.5 verified, firefox39 unaffected, firefox40 unaffected)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
Reproducible on:
Firefox 38.0.5b1-build1 (20150510205200)

Affected platforms:
Windows 7 (x64), Windows 8.1 (x86), Mac OS X 10.9.5, Ubuntu 14.04 (x64)

Steps to reproduce:
1. Launch Firefox.
2. Open a Reader View-compatible page, e.g. http://www.bbc.com/news/world-europe-32685942 or http://bits.blogs.nytimes.com/2015/03/30/the-path-toward-tomorrows-internet/?_r=0
3. Check the Browser Console.

Expected result:
* The example pages can be successfully displayed in Reader View.
* There are no error messages thrown for this action.

Actual result:
* The example pages can be successfully displayed in Reader View.
* The following error message is thrown by ReaderParent.jsm:95:12 in the Browser Console:
> ReferenceError: CustomizableUI is not defined

Additional notes:
* Nightly is NOT affected, as of 40.0a1 (2015-05-10).
* Aurora is NOT affected, as of 39.0a2 (2015-05-10).
* This issue might be a regression, I'll follow up with a regression range as soon as possible.
This sounds like bug 1158960, which was just uplifted.
Flags: needinfo?(jaws)
Flags: needinfo?(gijskruitbosch+bugs)

Updated

4 years ago
Duplicate of this bug: 1163589

Comment 3

4 years ago
This rebased mozilla-release landing:

https://hg.mozilla.org/releases/mozilla-release/rev/3e9805c11aa3

missed the CustomizableUI getter addition that in Nightly is blamed on the patch for bug 1155523 ( http://hg.mozilla.org/mozilla-central/annotate/d264b461947f/browser/modules/ReaderParent.jsm#l16 ), which is therefore now not present on either beta or release. I'm assuming we're overwriting beta with aurora later today? In which case, we just need to add that line on mozilla-release.
Flags: needinfo?(gijskruitbosch+bugs)
Posted patch PatchSplinter Review
Thanks for catching that Margaret and Gijs for the investigation. I checked mozilla-aurora and the line isn't missing there. I'm not sure how it got there but not on mozilla-release. Must have just been a mistake in a merge conflict.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Attachment #8604120 - Flags: review?(gijskruitbosch+bugs)

Updated

4 years ago
Attachment #8604120 - Flags: review?(gijskruitbosch+bugs) → review+
Comment hidden (obsolete, typo)
Approval Request Comment

[Feature/regressing bug #]: error in migration of patch in uplift of bug 1155523

[User impact if declined]: An error message is thrown by ReaderParent.jsm:95:12 in the Browser Console: ReferenceError: CustomizableUI is not defined

[Describe test coverage new/current, TreeHerder]: manual testing
[Risks and why]: low risk, single line missed on uplift. the line exists on other branches.
[String/UUID change made/needed]: none
Looking at this more, without this fixed users won't be able to add the current reader view page to Pocket from within reader view.
Comment on attachment 8604120 [details] [diff] [review]
Patch

a+ for mozilla-release, required for Pocket 38.0.5 launch
Attachment #8604120 - Flags: approval-mozilla-release? → approval-mozilla-release+
https://hg.mozilla.org/releases/mozilla-release/rev/195e873a8ab1

(Only needed as m-r, per comment 6. Other branches are fine.)
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Reporter

Updated

4 years ago
Flags: qe-verify+
QA Contact: alexandra.lucinet
Verified fixed with Firefox 38.0.5 beta 2 (Build ID: 20150514163436), under the following platforms: Windows 7 x64, Ubuntu 14.04 x64 and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.