Separators lose position in recent build

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: xyzzy, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({dataloss, regression})

Trunk
mozilla1.1alpha
dataloss, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I just grabbed build 2001121909, and on Windows 98, all of the separators in my
bookmarks seem to have floated to the top of their respective folders, losing
their placement within the folders.

Hopefully this is not due to the recent checkin for bug 114215.  This is highly
visible and results in data loss.
(Reporter)

Updated

16 years ago
Keywords: dataloss
(Reporter)

Comment 1

16 years ago
New serparators are generated at the bottom of the root folder, and don't seem
to be movable now either...

Comment 2

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben
Severity: critical → major
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Updated

16 years ago
OS: Windows 98 → All

Comment 3

16 years ago
Also happens on Mac.  All separators have floated to the top of the bookmark
menus and submenus.  All folders have also been relocated in the bookmark menus,
making most of them unintelligible.
mozilla1.1 is too late to fix this recent regression.  This is a dogfood issue.
Severity: major → critical
Keywords: mozilla0.9.8, nsdogfood, regression
Hardware: PC → All

Comment 4

16 years ago
This is a regression since the Jan 11, 2002 build, which worked properly for me.

Comment 5

16 years ago
*** Bug 121598 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
According to bug 121598, this is a regression from yesterday.

Comment 7

16 years ago
I started seeing this in 2002-01-24-03
(Reporter)

Comment 8

16 years ago
waldemar,

My original report shows that this has been an issue for me since late December,
not just yesterday.  Perhaps it was just less broken before yesterday?
waldemar, I don't think this is the same bug as recently duped bug 121598. This
bug has been ongoing for quite some time and also causes dataloss.  Bug 116362
does not and it just started occuring recently.  The bookmarks.html file is fine
in 116362 if you revert to an older build - everything is still in the proper
order.  Here in this bug it apparently does not.

Comment 10

16 years ago
for me I saw this before, november-december, then it was fixed since a month or
so, but It reappeared with 2002012403
(Reporter)

Comment 11

16 years ago
Bug 121777 is probably related to yesterday's regression reported as bug 121598,
duped against this.

Comment 12

16 years ago
Seems to be working again in today's build.
Keywords: mozilla0.9.8
(Reporter)

Comment 13

16 years ago
Yes, now that I've gotten 2002020409, WFM.

Comment 14

16 years ago
wfm Linux 2002011208, marking WORKSFORME, reopen if necessary.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.