[Find My Device] FMD UI does not enable properly if a network connection is established after the device boots up.

VERIFIED FIXED in Firefox 43

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Marty, Assigned: gerard-majax)

Tracking

({regression})

unspecified
FxOS-S6 (04Sep)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox43 fixed, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(7 attachments, 3 obsolete attachments)

(Reporter)

Description

4 years ago
Created attachment 8605570 [details]
logcat-fmd-cant-enable.txt

Description:
If the user is already signed in to a Firefox account, and they boot up their device without a WiFi or Data network connection, the FMD page will appropriately inform them that they must connect to a network to enable the feature.

After connecting to a network, if they attempt to enable the feature by tapping the "Create account or sign in" button, the button will highlight blue, but nothing will appear to happen.

After this, the list item for Find My Device on the main Settings menu will display that the feature is "Enabled"

Repro Steps:
1) Update a Flame to 20150512010209
2) Sign into a Firefox Account
3) Restart the device without a WiFi or Data network connection
4) Connect to a WiFi or Data network
5) Navigate to Find My Device
6) Tap the "Create account or sign in" button

Actual:
The button only highlights blue, and the list item for FMD on the main Settings menu will display "Enabled"

Expected:
The button will refresh the screen to display that the user is signed in, and allow the user to properly enable Find My Device

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150512010209
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: 502e1a5e722f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 8/8
See attached: Video (URL), Logcat
(Reporter)

Comment 1

4 years ago
This issue DOES occur on Flame 2.2, 2.1 builds.
The button only highlights blue, and the list item for FMD on the main Settings menu will display "Enabled"

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150513002507
Gaia: e048df68f6f4853b5826a8816e143d95258149de
Gecko: 0e6b4aab2b94
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
Build ID: 20150512001201
Gaia: c80865cb0bf73f1b97defbc646083b404feb3ac4
Gecko: 2fd3ef3fc14a
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

---------------------------------------------------------

This issue does NOT occur on Flame 2.0 builds.
The user is shown the normal Find My Device screen, and the user is able to enable the feature appropriately.

Environmental Variables:
Device: Flame 2.0 (319MB)(Full Flash)
Build ID: 20150512000208
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: 96101b9b9b2b
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:

User is given incorrect sign in screen that seems to have a broken button. Visible regression. Poor UX. Nominated to block 2.1
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: ktucker
QA Contact: ktucker
QA Contact: ktucker
Mozilla Inbound

Last Working
Environmental Variables:
Device: Flame 2.2
BuildID: 20141011160823
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 27fdae08d9d8
Version: 35.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken
Environmental Variables:
Device: Flame 2.2
BuildID: 20141011180623
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 37e8f50f6264
Version: 35.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 37e8f50f6264

First Broken Gaia Last Working Gecko: Issue DOES NOT reproduce
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 27fdae08d9d8

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=27fdae08d9d8&tochange=37e8f50f6264

This might have been caused by bug 1045738
Sam, can you take a look at this please? This might have been caused by the work done for bug 1045738.
Blocks: 1045738
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(spenrose)
Keywords: regressionwindow-wanted

Comment 5

4 years ago
(In reply to KTucker [:KTucker] from comment #4)
> Sam, can you take a look at this please? This might have been caused by the
> work done for bug 1045738.

The attached log implies that Gecko is probably working correctly -- it includes an FxA assertion and no FxA errors. The first step is to determine where in FMD's state machine it is unhappy. I am not sure who is currently maintaining FMD.
Flags: needinfo?(spenrose)
[Blocking Requested - why for this release]:
Continue fixing on next release
blocking-b2g: 2.1? → 2.5?
Hi Guilherme,
Could you help to find someone who can help here? Thanks!

Updated

3 years ago
Flags: needinfo?(guilherme.p.gonc+bmo)
blocking-b2g: 2.5? → 2.5+
Gregor, do you know anyone can take this bug?
Flags: needinfo?(anygregor)
(Assignee)

Comment 9

3 years ago
Push API was partly broken at that moment, and the logcat is useless: too short, no explanation on how/at which point it was acquired.
(In reply to Ken Chang[:ken] from comment #8)
> Gregor, do you know anyone can take this bug?

Nope. We have a regression window and I don't have anyone to investigate bugs from other teams.
David, what should we do here?
Flags: needinfo?(anygregor) → needinfo?(dscravaglieri)
Could we identify which part of FMD is broken ?
Flags: needinfo?(dscravaglieri)
From my test on Aries, it works. qawanted on this.
Keywords: qawanted
This issue still occurs on Aries Master, Flame Master and Flame 2.2

The "Create Account/Sign in" button when tapped does nothing after turning back on WiFi and Data. 

Device: Flame 2.5 (Full Flash)(KK)(319mb)
Build ID: 20150812030210
Gaia: c7875bbc8b32e7b95cc55c9690b03b140905d84d
Gecko: d4f3a8a75577e4af2914a4e899ca2e724f9715c4
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5 (Full Flash)(KK)(319mb)
Build ID: 20150812135535
Gaia: 6fef72357971934c8774578044ea7a442be3a75d
Gecko: b7efed3a2640fba681d48846c3b2ab80474c6f77
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.2 (Full Flash)(KK)(319mb
Build ID: 20150812032504
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 9295034c0ee3
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


STR:

1. Off a fresh flash, turn on data and sign into Firefox Accounts during the FTU.
2. Proceed to the home screen and turn off data. 
3. Reboot the phone and open settings. 
4. Tap on Find my Device and tap on "Create Account or Sign in".
5. The user will be notified that they are not connected to the network. Turn on data.
6. Tap the "Create Account or Sign in" button again.

Notice the button highlights but nothing happens.
Keywords: qawanted
(Assignee)

Comment 14

3 years ago
(In reply to KTucker [:KTucker] from comment #13)
> This issue still occurs on Aries Master, Flame Master and Flame 2.2
> 
> The "Create Account/Sign in" button when tapped does nothing after turning
> back on WiFi and Data. 

[...]

> 
> STR:
> 
> 1. Off a fresh flash, turn on data and sign into Firefox Accounts during the
> FTU.
> 2. Proceed to the home screen and turn off data. 
> 3. Reboot the phone and open settings. 
> 4. Tap on Find my Device and tap on "Create Account or Sign in".
> 5. The user will be notified that they are not connected to the network.
> Turn on data.
> 6. Tap the "Create Account or Sign in" button again.
> 
> Notice the button highlights but nothing happens.

Dumb question but does it works if you kill Settings app?
Flags: needinfo?(ktucker)
After encountering this issue, I force closed the settings app 5 times and the "Create account or sign in" was still not functional on Aries Master. I even tried restarting the device but the button still was not responding. 

Device: Aries 2.5
Build ID: 20150818012543
Gaia: d9d99f32762975a370f1abd34a3512bd6fe29111
Gecko: 90d9b7c391d38ae118865bd87b5d011feee6dded
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(ktucker)
(Assignee)

Comment 16

3 years ago
Right, so it might be a legit FMD-side issue. Could you collect full log during the whole process (i.e., accross both reboot), with the "Gaia debug" option turned on?
Flags: needinfo?(ktucker)
Created attachment 8649519 [details]
GaiaDebugLog.txt
Flags: needinfo?(ktucker)
(Assignee)

Comment 18

3 years ago
(In reply to KTucker [:KTucker] from comment #17)
> Created attachment 8649519 [details]
> GaiaDebugLog.txt

I cannot make use of this: only one file, does it contains both sequences ? Where should I split it ?

There's a timezone change in the middle, so I cannot read and follow anything while being sure of what is happening here ...
Flags: needinfo?(ktucker)
(Assignee)

Comment 19

3 years ago
And those logs shows a device being *registered* to FMD website. Which is inconsistent with STR where nowhere you ever enabled the feature. So I really need to know whether this got enabled because of the step "6. Tap the "Create Account or Sign in" button again." and that somehow we fail to properly feedback the user that we picked up his Firefox Accounts and registered successfully to FMD or if it is something else ...
(Assignee)

Comment 20

3 years ago
Should have read better comment 0: it states that it was working on 2.0. Let's get a regression window instead of throwing darts in the obscurity.
Keywords: regressionwindow-wanted
See comment 3 for regression window.
Keywords: regressionwindow-wanted
Flags: needinfo?(ktucker)
Duplicate of this bug: 1164710
(Assignee)

Comment 23

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #21)
> See comment 3 for regression window.

Right this one is still valid so? Then I really needs the proper logs before being able to do anything else.
Flags: needinfo?(pcheng)
Flags: needinfo?(ktucker)
QAwanted to get another log strictly following original STR and indicate where in the log is point of reboot.
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Created attachment 8651172 [details]
logcat part 1 of 2

I found that strictly following STR at comment 0 doesn't repro the bug. It seems that after reboot I have to attempt to enable FMD without internet, at that point connect to internet, do the rest of STR and the bug occurs.

Attaching part 1 of 2 of a 2-part logcat. This part 1 ends when the device is powered off.
Flags: needinfo?(pcheng)
Flags: needinfo?(ktucker)
Created attachment 8651173 [details]
logcat part 2 of 2

Part 2 of logcat starts as soon as the device is booting up.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(Assignee)

Comment 27

3 years ago
Thanks Pi Wei. Given your comment 25, it would be really helpful if you could update the current set of clear STR :)
Flags: needinfo?(pcheng)
Updated STR:
0) Connect to internet
1) Sign into a Firefox Account via Settings
2) Disconnect from internet
3) Reboot the device
4) Navigate to Settings > Find My Device > tap on Create account or sign in
5) When notified that there's no internet connection, connect to internet, and observe the button "create account or sign in" doesn't change after connected to internet, also tapping on it does nothing.
Flags: needinfo?(pcheng)
(Assignee)

Comment 29

3 years ago
Ok, it looks that with those STRs I'm reproducing easily. No idea yet of what is happening :(
Flags: needinfo?(guilherme.p.gonc+bmo)
(Assignee)

Comment 30

3 years ago
So it seems that I reproduce this but I'm not 100% sure. Pi Wei can you get me a screenshot of the first panel of Settings app after step 5 ?

And also if you kill and restart Settings after this same step ?

In my case, I have the "Enabled" string below "Find My Device" but still the "Create account or sign in" button visible.

As much as I could investigate, when we tap on the button we are hitting: https://github.com/mozilla-b2g/gaia/blob/109cbbd3a6b480e06e184df72a5e4452c8e69bab/apps/findmydevice/js/findmydevice.js#L297

Mark, do you have an idea ?
Flags: needinfo?(pcheng)
Flags: needinfo?(mgoodwin)
I see what you see as well, after step 5, on first panel of Settings it would say FMD is enabled, but if I tap into FMD, the "create account or sign in" button is still there.
Flags: needinfo?(pcheng)
(Assignee)

Comment 32

3 years ago
Created attachment 8653606 [details] [diff] [review]
fmd-debug.patch

Pi Wei, can you apply this and collect logs? To see if you get the same exact behavior as me.
Flags: needinfo?(pcheng)
I am not sure how to apply that patch. Could you give some instructions? Or I can ask Naoki to give me a build that has that patch.
Actually, nvm I got instructions from Jayme on how to apply that patch. Flagging QAwanted on this task (I'll be doing it).
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
(Assignee)

Comment 35

3 years ago
So right now I get push registration failures ...
(Assignee)

Comment 36

3 years ago
I am experiencing the exact same condition of connection reset as the one documented on bug 1189729 comment 46. So I cannot investigare more :(
Flags: needinfo?(kcambridge)
Created attachment 8653639 [details]
log with FMD debug enabled starting after reboot

Attaching the log with FMD debug enabled. I started the log after rebooting the device. After bug reproduces I also tried killing settings app and reopening to find issue still there.
Flags: needinfo?(pcheng) → needinfo?(lissyx+mozillians)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
(In reply to Alexandre LISSY :gerard-majax from comment #36)
> I am experiencing the exact same condition of connection reset as the one
> documented on bug 1189729 comment 46. So I cannot investigare more :(

Are you on Wi-Fi or cellular? Any proxies? Do other WebSocket-based apps work?
Flags: needinfo?(kcambridge)
(Assignee)

Comment 39

3 years ago
(In reply to Kit Cambridge [:kitcambridge] from comment #38)
> (In reply to Alexandre LISSY :gerard-majax from comment #36)
> > I am experiencing the exact same condition of connection reset as the one
> > documented on bug 1189729 comment 46. So I cannot investigare more :(
> 
> Are you on Wi-Fi or cellular? Any proxies? Do other WebSocket-based apps
> work?

H+ with Bouygues Telecom. No proxy. I can tell that this was working on this device earlier (weeks ago).
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Comment 40

3 years ago
Pi Wei, it looks like I diverging from you since you receive push properly.
Flags: needinfo?(pcheng)
I would suggest on factory resetting the phone but it looks like you've been dogfooding so maybe use another device? This also reproduces on Flame.
Flags: needinfo?(pcheng)
(Assignee)

Comment 42

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #41)
> I would suggest on factory resetting the phone but it looks like you've been
> dogfooding so maybe use another device? This also reproduces on Flame.

Yeah it's not really dogfooding but the problem is I need another Firefox Accounts otherwise it will be a mess. That being said, the logs indicates that in fact FMD is properly enabled and that it is just the user feedback that breaks.

If I'm right, it means you should be able to use FMD's website and track/lock/ring your device properly, with and without my patch.
Flags: needinfo?(pcheng)
I wouldn't be surprised if FMD was actually auto enabled once they reconnect after reboot, it's just that the UI is confusing and incorrect on that FMD page on the phone. If you read comment 0 the actual result does mention what we're seeing right now.
Flags: needinfo?(pcheng)
(Assignee)

Comment 44

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #43)
> I wouldn't be surprised if FMD was actually auto enabled once they reconnect
> after reboot, it's just that the UI is confusing and incorrect on that FMD
> page on the phone. If you read comment 0 the actual result does mention what
> we're seeing right now.

Yeah but I would like confirmation and since Push is broken for me I solely rely on you :).

If FMD itself is properly connected and usable, it's just probably the Settings app part that gets crazy. If we have the Enabled status true but that the feature is broken, it's much more serious.
Flags: needinfo?(pcheng)
(Assignee)

Comment 45

3 years ago
So the suspect would be that togglePanel does not gets called with "true". This means we have something going on.  This setting value is controlled by code in apps/system/js/findmydevice_launcher.js and will be toggled to true or false depending on what is sent from the Firefox Accounts chrome event.
Summary: [Find My Device] FMD does not enable properly if a network connection is established after the device boots up. → [Find My Device] FMD UI does not enable properly if a network connection is established after the device boots up.
(Assignee)

Updated

3 years ago
Assignee: nobody → lissyx+mozillians
(Assignee)

Comment 46

3 years ago
Right the setting gets set because of the |SettingsHelper('findmydevice.logged-in').set(false);| call in the onerror handler in |navigator.mozId.watch()| in apps/settings/js/findmydevice.js.

The value of |err| at that moment is "{}". I am wondering if the bug would not be on the FxA Gecko side now, since given the steps we are offline when this |onerror| handler gets called and there is a check for |err !== "OFFLINE"|. Hence, shouldn't we receive an |err| object which value is |"OFFLINE"| rather than |"{}"| ?
(In reply to Alexandre LISSY :gerard-majax from comment #30)
> As much as I could investigate, when we tap on the button we are hitting:
> https://github.com/mozilla-b2g/gaia/blob/
> 109cbbd3a6b480e06e184df72a5e4452c8e69bab/apps/findmydevice/js/findmydevice.
> js#L297
> 
> Mark, do you have an idea ?

The log in comment 37 confirms you are correct in this.

(In reply to Alexandre LISSY :gerard-majax from comment #46)
> shouldn't we receive an |err| object which value is
> |"OFFLINE"| rather than |"{}"| ?

I would have thought so.
Flags: needinfo?(mgoodwin)
(Assignee)

Comment 48

3 years ago
So FMD Settings code expects a JSON object coming out of the onerror handler, with a "name" property. However, the mozId API implementation will return strings.
(Assignee)

Comment 49

3 years ago
Ok, once the proper OFFLINE error pops to Settings app, the bug is fixed.
(Assignee)

Comment 50

3 years ago
Created attachment 8654084 [details]
Firefox Accounts gecko patch

Pi Wei, applying this on your Gecko and then trying to reproduce the issue should make the bug being fixed.

However, I might still have to hack on Gaia side for people that are already blocked: we need to change the |findmydevice.logged-in| value.
Flags: needinfo?(pcheng)
(Assignee)

Comment 51

3 years ago
Comment on attachment 8654084 [details]
Firefox Accounts gecko patch

Fernando, this should follow your recommandation for not breaking Android. As far as I could test, this fixes the present issue where the lack of proper error reporting was putting FMD Settings panel in an unexpected state.
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 52

3 years ago
Switched over WiFi in the office, Push worked and after a few times/retry of debugging, I'm getting TCP RST again. Both on data (LTE) and WiFi (Mozilla Guest).
Flags: needinfo?(kcambridge)
(Assignee)

Comment 53

3 years ago
Created attachment 8654109 [details] [diff] [review]
fmd-debug.patch

Pi Wei, if you could test applying this Gaia patch after the Gecko one, this should make sure we do not let the user in a broken state.
Attachment #8653606 - Attachment is obsolete: true
Flags: needinfo?(pcheng)
(Assignee)

Comment 54

3 years ago
So to state it clearly, I'd like that you check on your side with:
 (1) fresh profile, no gecko fix: we expect to see the error
 (2) fresh profile, only gecko fix: we expect to not see the error any more
 (3) fresh profile, no gecko fix, reproduce the error, then apply gecko fix: we should still see the broken panel
 (4) fresh profile, no gecko fix, reproduce the error, then apply gecko and gaia fix, and we should now have everything fixed

The Gaia part is only indented to unlock people with a broken state. We are reacting on the MozID API's login/logout callback fired, so it should be safe that we set the setting value from there.
(Assignee)

Comment 55

3 years ago
Comment on attachment 8654109 [details] [diff] [review]
fmd-debug.patch

Mark, inside the debug you can see this change in the Settings panel:
> +      // Bug 1164713: Force logged in status in case of stale setting value
> +      SettingsHelper('findmydevice.logged-in').set(loggedIn);
> +

The goal is to unblock people who are in the broken state where |findmydevice.logged-in| has been erroneously set to false. The value |loggedIn| we are forcing comes straight from the MozID API.
Attachment #8654109 - Flags: feedback?(mgoodwin)
Comment on attachment 8654109 [details] [diff] [review]
fmd-debug.patch

This looks to be a sensible approach.
Attachment #8654109 - Flags: feedback?(mgoodwin) → feedback+
We are not set up to apply Gecko patches. We can only do things Gaia related.
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Comment 58

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #57)
> We are not set up to apply Gecko patches. We can only do things Gaia related.

I'm sorry but you have to find a way ...
Flags: needinfo?(lissyx+mozillians)
I'll take a further look into getting a build for them and such.
Flags: needinfo?(nhirata.bugzilla)
Thanks, Naoki.

Alexandre,

I won't be able to test (3) and (4) of comment 54. I can do half of (4) which is applying gaia fix on top of gecko fix build.
(Assignee)

Comment 61

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #60)
> Thanks, Naoki.
> 
> Alexandre,
> 
> I won't be able to test (3) and (4) of comment 54. I can do half of (4)
> which is applying gaia fix on top of gecko fix build.

Well you can just play around with profiles if it helps: for (3) and (4) generate the error on a profile, keep it and push a Gecko with the fix. Or reflash the whole device with a Gecko that has the fix and restore the profile.
Flags: needinfo?(ferjmoreno)
Attachment #8654084 - Flags: feedback+
fyi both patches have white space:
../../patches/file_1164713.patch:10: trailing whitespace.
    return Promise.reject(reason.message ? { error: reason.message } : reason);
warning: 1 line adds whitespace errors

../../patches/fmd-debug.patch:399: tab in indent.
	}
../../patches/fmd-debug.patch:401: trailing whitespace.
      
warning: 2 lines add whitespace errors.
(Assignee)

Updated

3 years ago
Keywords: qaurgent
(Assignee)

Updated

3 years ago
Attachment #8654084 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Attachment #8654109 - Attachment is obsolete: true
Created attachment 8654894 [details] [review]
[gaia] lissyx:bug1164713 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8654894 - Flags: review?(mgoodwin)
Comment on attachment 8654884 [details] [diff] [review]
Return error string from FxAccounts

Review of attachment 8654884 [details] [diff] [review]:
-----------------------------------------------------------------

r=me. But file a follow up to check and normalize error reporting on FxA, please. Thanks!
Attachment #8654884 - Flags: review?(ferjmoreno) → review+
(Assignee)

Comment 66

3 years ago
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #65)
> Comment on attachment 8654884 [details] [diff] [review]
> Return error string from FxAccounts
> 
> Review of attachment 8654884 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=me. But file a follow up to check and normalize error reporting on FxA,
> please. Thanks!

Filed as bug 1200284
Ran into issue building on Mac where the device wouldn't start.  Still investigating that issue.

Meanwhile Johan pinged me to build on taskcluster, I had not done this.  I should have.  Spun the build: https://tools.taskcluster.net/task-inspector/#u3ZPZSuKSkeittrr_L_y_Q/1
(Assignee)

Comment 68

3 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #67)
> Ran into issue building on Mac where the device wouldn't start.  Still
> investigating that issue.
> 
> Meanwhile Johan pinged me to build on taskcluster, I had not done this.  I
> should have.  Spun the build:
> https://tools.taskcluster.net/task-inspector/#u3ZPZSuKSkeittrr_L_y_Q/1

Kernel built on Mac are non booting, that is a known fact but as you see I cannot be everywhere ...
https://tools.taskcluster.net/task-inspector/#u3ZPZSuKSkeittrr_L_y_Q/1  Task cluster build is complete.  Haven't tested.  Will ask Pcheng to take a look.
Flags: needinfo?(nhirata.bugzilla)
The build that Naoki gave us contains both Gaia & Gecko fixes. So the following is the best that I can do:

 (1) fresh profile, no gecko nor gaia fix:

Bug reproduced.

 (2) fresh profile, with gecko + gaia fixes:

Bug still reproduced (panel was still broken after doing STR). FMD functionality was enabled properly, I was able to locate, ring, lock, or factory reset the device.

 (3) old profile used at (1) that reproduced bug, on a build with gaia + gecko fixes:

Firefox sign-in status seemed to be erased after I connected to internet on old profile. At first it seemed like it was reproducing the bug, but after about a minute, my sign in status was lost and it became a valid 'create account or sign in' action, but under Settings main page the Find My Device section still says 'Enabled'.
Flags: needinfo?(pcheng)
Keywords: qaurgent
(Assignee)

Comment 71

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #70)
> The build that Naoki gave us contains both Gaia & Gecko fixes. So the
> following is the best that I can do:
> 
>  (1) fresh profile, no gecko nor gaia fix:
> 
> Bug reproduced.
> 
>  (2) fresh profile, with gecko + gaia fixes:
> 
> Bug still reproduced (panel was still broken after doing STR). FMD
> functionality was enabled properly, I was able to locate, ring, lock, or
> factory reset the device.
> 
>  (3) old profile used at (1) that reproduced bug, on a build with gaia +
> gecko fixes:
> 
> Firefox sign-in status seemed to be erased after I connected to internet on
> old profile. At first it seemed like it was reproducing the bug, but after
> about a minute, my sign in status was lost and it became a valid 'create
> account or sign in' action, but under Settings main page the Find My Device
> section still says 'Enabled'.

So, you are stating none of my fix help? That's totally inconsistent with my experience :(
Flags: needinfo?(pcheng)
(Assignee)

Comment 72

3 years ago
I have repaired Push on my device and I confirm that without the fixes I reproduce the bug. Flashing a Gecko/Gaia with the fixes and tapping the "Create an account or sign-in" on a device that got bugged, but with both patches, I get FMD properly enabled and then the panel properly toggled.
Comment on attachment 8654894 [details] [review]
[gaia] lissyx:bug1164713 > mozilla-b2g:master

This looks good to me.

Thanks!
Attachment #8654894 - Flags: review?(mgoodwin) → review+
Since this has landed I'll try to verify this on the next nightly. It is possible that Naoki didn't create the build correctly or that it was created without fixes. QAwanted to verify this on master on next nightly.
Keywords: qawanted
(Assignee)

Comment 77

3 years ago
(In reply to Pi Wei Cheng [:piwei] from comment #76)
> Since this has landed I'll try to verify this on the next nightly. It is
> possible that Naoki didn't create the build correctly or that it was createdia 
> without fixes. QAwanted to verify this on master on next nightly.

Only the Gaia part landed. Gecko is waiting for sherrif to merge. I doubt it will be in next nightly.
We'll test this on inbound once Gecko has landed.
https://hg.mozilla.org/mozilla-central/rev/84e10095363e
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S6 (04Sep)
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(pcheng)
QA Contact: ktucker → pcheng
status-b2g-master: affected → fixed
This issue is verified fixed on Aries and Flame 2.5 master. At step 4 of comment 28 I now see I'm signed in to my Firefox account and it takes me to the 'enable find my device' page. If I tap on that toggle it informs me that I'm offline. If I connect to internet it lets me toggle FMD on. Everything works as expected - I was able to locate, ring, lock, and erase my device from FMD website. Related FMD options reflected my current status as well.

Verified fixed on (using latest b2g-inbound builds):
Device: Aries 2.5
BuildID: 20150902162208
Gaia: 4d8aeb0c301250f3696dda44a8518c70d9ac196a
Gecko: e837c54cfe87b8a493c43a08ff217d8db652b230
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
BuildID: 20150902082123
Gaia: 4d8aeb0c301250f3696dda44a8518c70d9ac196a
Gecko: e837c54cfe87b8a493c43a08ff217d8db652b230
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Flags: needinfo?(jmercado)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
(Assignee)

Comment 82

3 years ago
\o/ Thanks Pi Wei for the confirmation \o/
Verify this again on Central when it lands there to be safe.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: verifyme
Figured out the difference.  The gecko change wasn't committed so it would have made both gecko/gaia patch not in the build.  I'll be sure to verify that the build has the changes commit before building on task cluster next time.  *sigh*
Flags: needinfo?(kcambridge)
This issue is verified fixed on nightly again. At first it had a difficult time showing my device location on FMD website map, I'm not sure if it's just geolocation functioning improperly or something else. I wasn't able to repro it consistently so not bothering writing that up.

Verified fixed on:
Device: Flame 2.5
BuildID: 20150904030224
Gaia: d7385b79e68d4ad662cacf810506e9ee53345d23
Gecko: 7f987c38bd3e5ac9a834981e85378bdb02338e9d
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Aries 2.5
BuildID: 20150904191331
Gaia: 03be7d8918bed58c92a40bba211bbbc97a0e516a
Gecko: 538ccb262ec9f022b198d5fbe57a9c99c7eee9b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.