Closed Bug 1164828 Opened 6 years ago Closed 5 years ago

(Build 15) Wrong alignment of search engines in Settings in localized builds

Categories

(Firefox for iOS :: General, defect)

Other
iOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fennec + ---

People

(Reporter: flod, Assigned: bnicholson)

References

Details

Attachments

(2 files)

Attached image Screenshot iOS Italian
iOS set to Italian, check the alignment in the screenshot: Twitter's name is misaligned compared to the other search engines.

All search engines have 32px icon, so not sure what's causing it.
The issue is that you're shipping 128px icons for English, while we stop at 32px on Android. That's causing the misalignment and the grainy image.
Summary: (Build 15) Wrong alignment of search engines in Settings → (Build 15) Wrong alignment of search engines in Settings in localized builds
tracking-fennec: --- → ?
I vote to track, and expect this to be an easy fix.
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #1)
> The issue is that you're shipping 128px icons for English, while we stop at
> 32px on Android.

Android is adding hi-res icons as well (bug 1156917), so we should look into hi-res images for all locales. Filed bug 1164963.
Assignee: nobody → bnicholson
tracking-fennec: ? → +
Status: NEW → ASSIGNED
Comment on attachment 8608340 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/482

I think the scaling of the image is fine. The other fix for this would be to create a custom UITableViewCell subclass and set the UIImageView's frame to a fixed size in layoutSubviews or constraints using autolayout. That's more of a refactor though. I'm good with the scaling for now.
Attachment #8608340 - Flags: review?(sleroux) → review+
Also cool thing I just found using the new view debugging tools in Xcode 6 that might help in debugging issues like these in the future is the 'Show View Frames' feature:

https://www.dropbox.com/s/1vrqn37cwsabewo/Screenshot%202015-05-21%2010.12.12.png?dl=0
(In reply to Stephan Leroux from comment #5)
> I think the scaling of the image is fine. The other fix for this would be to
> create a custom UITableViewCell subclass and set the UIImageView's frame to
> a fixed size in layoutSubviews or constraints using autolayout.

Yeah, that was actually the first thing I tried. It resized the image fine, but the text was still misaligned (i.e., the "Google" from your screenshot was still out of place). I guess we'd need to change the label frame too if we went with that approach.

'Show View Frames' looks pretty cool!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This actually still affects the pane used to select the default search engine. Should this be reopened or a new bug filed?
New bug please
Depends on: 1170856
Filed bug 1170856 as a follow-up.
You need to log in before you can comment on or make changes to this bug.