Unexpected server error while validating

VERIFIED FIXED in 2015-07

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: transitory, Assigned: kmag)

Tracking

unspecified
2015-07

Details

Attachments

(1 attachment)

3.35 KB, application/x-xpinstall
Details
(Reporter)

Description

4 years ago
Created attachment 8605821 [details]
linkozela@history.xpi

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150511103818

Steps to reproduce:

Kris Maglione asked me to file a bug for this issue. Trying to validate addon, check compatibility or submit a new addon. 


Actual results:

Addon fails validation process with error 

100% complete · 3.35 KB of 3.35 KB
Your add-on failed validation with 1 error.

    Unexpected server error while validating. 


Expected results:

to go through or get meaningful feedback.
Component: Untriaged → Add-on Validation
Product: Firefox → addons.mozilla.org
Version: 38 Branch → unspecified
I can easily reproduce this at https://addons.mozilla.org/developers/addon/validate. The error is pretty much instantaneous and the add-on too small and simple to cause a timeout.
Assignee: nobody → kmaglione+bmo
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

3 years ago
Experiencing the same issue.
Can't upload/update add-ons since yesterday (29-06-2015).
Add-ons validator hangs at 100%.
Is anyone looking into this?
(In reply to Aris from comment #2)
> Experiencing the same issue.
> Can't upload/update add-ons since yesterday (29-06-2015).
> Add-ons validator hangs at 100%.
> Is anyone looking into this?

That's a separate issue. There was a temporary server problem with the validator that should have been fixed this morning.
This fixes http://sentry.mktmon.services.phx1.mozilla.com/mkt/addonsmozillaorg/group/15975/

Kris, can you please give STRs? Is there something we can add to an extension to reproduce the error?
Flags: needinfo?(kmaglione+bmo)
(Assignee)

Comment 6

3 years ago
The simplest STR:

1) Upload the extension in comment 0.
2) See validation error.

More complicated, STR:

1) Create a chrome manifest with a chrome content package pointing at '/'. E.g.,

content linkozela /

2) Add an overlay line pointing to a chrome URL in this package. E.g.,

overlay	chrome://browser/content/browser.xul	chrome://linkozela/content/linkozela.xul

3) Attempt to attach a script via that overlay.
Flags: needinfo?(kmaglione+bmo)

Comment 7

3 years ago
Commits pushed to master at https://github.com/mozilla/amo-validator

https://github.com/mozilla/amo-validator/commit/fd43f8a64cd85c6cd12bc51e5d23f036b05c09b2
Bug 1164836: Fix the resolution of chrome content packages pointing to '/'.

https://github.com/mozilla/amo-validator/commit/efc65256edfe14d80a3ec37decadc7020b02149e
Merge pull request #295 from kmaglione/bug-1164836

Bug 1164836: Fix the resolution of chrome content packages pointing to '/'
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-07

Comment 8

3 years ago
I've downloaded the extension from comment #0 and tried to validate it with the Addon Validator on AMO-dev but I receive the same message "Unexpected server error while validating." without any further instructions.
Please see the screencast: http://screencast.com/t/NOHxxSgjyxEA
Reopening.
Status: RESOLVED → REOPENED
Flags: needinfo?(kmaglione+bmo)
Resolution: FIXED → ---
(Assignee)

Comment 9

3 years ago
This is fixed in the validator, but the new version hasn't been pushed to any servers yet.

I'll leave open for now and close again once a release has been cut.
Flags: needinfo?(kmaglione+bmo)
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 10

3 years ago
Verified as fixed on AMO-dev FF39(Win 7)
Postfix screencast: http://screencast.com/t/Ce9BruXRdru
Closing bug.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.