If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Port Thunderbird Bug 1130248 (Allow email addresses in address name fields)

RESOLVED FIXED in seamonkey2.38

Status

SeaMonkey
MailNews: General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.38
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.35 fixed, seamonkey2.36 fixed, seamonkey2.37 fixed, seamonkey2.38 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Fixes:
> TB Bug 1130248 - |To: "foo@example.com" <foo@example.com>| becomes |"foo@example.comfoo"@example.com| when I compose mail to it
> TB Bug 1162477 - Bad to address when replying to message (jsmime problem?)
(Assignee)

Comment 1

2 years ago
Created attachment 8606672 [details] [diff] [review]
Patch v1.0 Port changes from Thunderbird.

Bug 1130248 landed on all branches including comm-aurora, TB 39, TB 38
Attachment #8606672 - Flags: superreview?(mnyromyr)
Attachment #8606672 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

2 years ago
status-firefox41: affected → ---
status-seamonkey2.35: --- → affected
status-seamonkey2.36: --- → affected
status-seamonkey2.37: --- → affected
status-seamonkey2.38: --- → affected

Updated

2 years ago
Attachment #8606672 - Flags: review?(iann_bugzilla) → review+

Comment 2

2 years ago
Comment on attachment 8606672 [details] [diff] [review]
Patch v1.0 Port changes from Thunderbird.

(By inspection.)
Attachment #8606672 - Flags: superreview?(mnyromyr) → superreview+
(Assignee)

Comment 3

2 years ago
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/7636eb8e94b6
Target Milestone: --- → seamonkey2.38
(Assignee)

Comment 4

2 years ago
Comment on attachment 8606672 [details] [diff] [review]
Patch v1.0 Port changes from Thunderbird.

[Approval Request Comment]
Regression caused by (bug #): bug 858337
User impact if declined:
1.To: "foo@example.com" <foo@example.com>| becomes |"foo@example.comfoo"@example.com| when I compose mail to it
2. Bad to address when replying to message
Testing completed (on m-c, etc.): Tested in Thunderbird landed on all TB branches
Risk to taking this patch (and alternatives if risky): low risk regression fix.
String changes made by this patch: None.
Attachment #8606672 - Flags: approval-comm-release?
Attachment #8606672 - Flags: approval-comm-beta?
Attachment #8606672 - Flags: approval-comm-aurora?
(Assignee)

Updated

2 years ago
See Also: → bug 1164356

Updated

2 years ago
Attachment #8606672 - Flags: approval-comm-beta?
Attachment #8606672 - Flags: approval-comm-beta+
Attachment #8606672 - Flags: approval-comm-aurora?
Attachment #8606672 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

2 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/312d8a685098
http://hg.mozilla.org/releases/comm-beta/rev/d9530439f36c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-seamonkey2.36: affected → fixed
status-seamonkey2.37: affected → fixed
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
status-seamonkey2.38: affected → fixed
(Assignee)

Updated

2 years ago
Blocks: 1177041

Updated

2 years ago
Attachment #8606672 - Flags: approval-comm-release? → approval-comm-release+
(Assignee)

Comment 6

2 years ago
http://hg.mozilla.org/releases/comm-release/rev/dda9863a023d
status-seamonkey2.35: affected → fixed
You need to log in before you can comment on or make changes to this bug.