Closed Bug 1165670 Opened 8 years ago Closed 7 years ago

Reader Mode first-time notification is too aggressive. (Covers up page-content, steals keyboard focus, appears on pages where it's not useful, & must be manually clicked to be dismissed)

Categories

(Toolkit :: Reader Mode, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1162750
Tracking Status
firefox39 --- affected
firefox40 --- affected
firefox41 --- affected
firefox42 --- affected
firefox-esr31 --- unaffected

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(2 files)

STR:
 1. Open Firefox Nightly with a new profile.
   (Or start Firefox nightly with a profile that has previously only been opened in Firefox Release.)

 2. Visit any of the following sites:
  Citibank login page:
     https://online.citibank.com/US/JSO/signon/LocaleUsernameSignon.do
  HTTPS Everywhere Download page:
     https://www.eff.org/https-everywhere
  Some themed sale at woot.com:
     http://www.woot.com/plus/fila-fila-in-groovy

  (none of these would benefit from being viewed in "reader mode")

ACTUAL RESULTS:
 - A Reader Mode popup appears, offering to "Remove clutter so you can focus exactly on what you want to read".
 - If I ignore the popup, it stays there -- blocking the page's content -- until I manually click its close button (or switch tabs, or click a link). Clicking a blank area on the page doesn't make it go away.
 - If I'm intrigued by the popup and click reader-mode, I get something useless, because these pages aren't content that's suitable to being displayed in reader mode. (At the Woot link above, for example, I just get a reader-mode view of a single paragraph of legal disclaimer and nothing else.)

EXPECTED RESULTS:
 - No intrusive reader mode popup, or at least only a popup when we're reasonably confident we're on a page where it'll be useful.
 - To the extent that a popup is shown: it shouldn't block page content, or if it does, it should be much easier to dismiss. (Please don't make me click its "x"; I just want to see the page I'm on.)
(Note: this may be more annoying for me (and other Firefox devs) than for the average user, because I perform something like this bug's STR many times per day, so I get spammed by this popup very frequently.

For me, the particularly annoying bit about this notification is that it *covers up part of the page* (as compared to the "you're testing e10s!" and "See what data gets submitted" notifications, which just shrink the viewport slightly & hence are easier to ignore.

There's also a certain frustrating irony to the fact that it only has one sentence, which is about "removing clutter so you can focus", and yet the popup itself *is* clutter which is stealing my visual focus.)
Summary: Reader Mode "remove clutter" first-time notification is too aggressive. (Appears on pages where it's not useful, covers up page content, & must be manually dismissed) → Reader Mode first-time notification is too aggressive. (Covers up page-content, appears on pages where it's not useful, & must be manually clicked to be dismissed)
[Tracking Requested - why for this release]: Intrusive popup, which is attempting to highlight a new feature, is currently just as likely to cause user annoyance/frustration/notification-fatigue.
Here's a screenshot showing this popup (plus the other 2 firstrun notifications) on the citibank login page.

(As is the case at woot: if I optimistically take the popup up on its offer, & click the "reader mode" icon, I end up seeing a nicely-formatted version of citibank's bottom-of-the-page legal blurb.)
Tracked for 41, so that a fix is implemented to prevent annoying users.
IMO this should block shipping reader mode (bug 558882). See ACTUAL RESULTS in comment 0 for description of issue.
(In reply to Daniel Holbert [:dholbert] from comment #5)
> IMO this should block shipping reader mode (bug 558882).

(Er, never mind; I guess reader mode already shipped enabled-by-default in Firefox 38.0.5 (and 39), based on local testing.)
[Canceling tracking-41, since this isn't actually a new thing in 41, & setting other versions after this feature shipped as 'affected'.]
This bug still annoys the heck out of me. Any chance we can disable this notification now?  Do we still need to pop it up on the first page that smells like there's a chance it might be enhanced by reader mode?

It still pops up on completely inappropriate pages like e.g. http://codepen.io/browles/pen/pgdMbK , and it still refuses to go away until I click its teeny "x" target
(Again, only happens in fresh profiles, but I'm constantly working with fresh profiles, as a Firefox developer.)
ni=Florian to comment on whether we can disable this spammy popup, since it looks like he was involved with this reader work at one point (in bug 1136570).
[er, forgot to set needinfo; setting now]
Flags: needinfo?(florian)
Based on the discussion in bug 1210366, it seems like we're not ready to turn this off yet but there are a few things we can do to help you (I also find this annoying because of @noautohide=true):
* Block reading view on codepen.io and others you find that are obviously inappropriate (see the patch in bug 1210366)
* Increase the close button click target size (see also bug 1150163 and bug 1199716 about tweaking the close button)
Flags: needinfo?(florian)
Product: Firefox → Firefox Graveyard
Component: Reading List → Reader Mode
Product: Firefox Graveyard → Toolkit
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1162750
One more gripe with this popup that hasn't yet been noted: it steals keyboard focus.

So e.g. if I'm browsing an article with PageUp/PageDown or arrow keys, and then this popup appears, it actively steals keyboard-focus & I'm suddenly unable to continue scrolling the article with the keyboard. (I have to manually grab my mouse and click on the article to restore focus.)

(This might actually be a bug with our popup code, because the problem actually fixes itself if I alt-tab away & back again -- the popup is still visible but focus is returned to the article... so I'll file that separately.)
Summary: Reader Mode first-time notification is too aggressive. (Covers up page-content, appears on pages where it's not useful, & must be manually clicked to be dismissed) → Reader Mode first-time notification is too aggressive. (Covers up page-content, steals keyboard focus, appears on pages where it's not useful, & must be manually clicked to be dismissed)
Filed bug 1258765 on the keyboard focus issue discussed in comment 14.
You need to log in before you can comment on or make changes to this bug.