Closed Bug 1165705 Opened 6 years ago Closed 5 years ago

Feed URL field cutoff bottom part of text with windows classic theme (no underscore)

Categories

(Thunderbird :: Theme, defect)

31 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 49.0

People

(Reporter: scootergrisen, Assigned: Paenglab)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

In Windows 7, rightclick the desktop and select personal settings.

Change the theme to windows classic.

In Thunderbird click Feeds and Blogs.

Click Manage subscriptions

Write an URL containing underscore (_) in the Feed URL field.


Actual results:

The underscore does not show because the bottom part og the text is cut off.


Expected results:

The bottom part of the text should also be visible.
It looks like rssFeedInfoBox etc height needs to be 2.4em instead of 2.3em, everywhere or only win.
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Theme
Ever confirmed: true
alta88, why do we need to define a height for #rssFeedInfoBox row? Wouldn't it be enough to to define it for #statusContainerBox?
Flags: needinfo?(alta88)
Oh, it's entirely possible we don't.  If I recall, the issue is that menulist text doesn't (or didn't) line up properly with labels in the row.  Which is a core problem found elsewhere too; it was worse here since the whole grid 'moved' when changing to an item with the menulist *and* in addition it's a folderpicker menulist with an icon.

I think if you have a better css way (baseline?) of ensuring labels and menulists look nice and don't 'jiggle' when switching between a folder and a subscription in this widget that would work too.

It would be great if no special css were needed in this widget.  Or it could be that using height is the simplest fix.
Flags: needinfo?(alta88)
Attached patch subscribe.patchSplinter Review
This patch fixes the issue with the cut off text.

The align="center" of the hbox around the #locationValue textbox made them shrink and not have the same height as the other textboxes. Also reduce the padding made more place for the text. On Windows  default themes the textboxes are correct with 2.3em height. Classic needs 2.4em.

OS X needs no change.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8750088 - Flags: review?(alta88)
Comment on attachment 8750088 [details] [diff] [review]
subscribe.patch

Review of attachment 8750088 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, wfm (tested on linux).
Attachment #8750088 - Flags: review?(alta88) → review+
http://hg.mozilla.org/comm-central/rev/f845c406cebd
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 49.0
You need to log in before you can comment on or make changes to this bug.