Dev theme, Menu text and toolbutton is almost invisible on Windows7 Classic

VERIFIED FIXED in Firefox 41

Status

()

Firefox
Theme
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: bgrins)

Tracking

({regression})

41 Branch
Firefox 42
regression
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox40 ?, firefox41+ verified, firefox42 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
[Tracking Requested - why for this release]:

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/2f6ea66057fe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 ID:20150517030204

This happens on Windows7 Classic Style.
This happens if Titlebar disabled and not maximized window.

STR
1. Switch to Dev theme if not


Actual Results:
Menu text is almost invisible.
   (Black text and Dark blue background)

Toolbutton is not invert color in NavBar and MenuBar
   (Black button image and Dark blue background)

Expected Results:
The browser UI should be readable

Comment 1

3 years ago
I can confirm this:

Build: https://hg.mozilla.org/releases/mozilla-aurora/rev/24460b808b17
ID: 20150517004004

Firefox 32-bit, on Win7 x64 with classic style and no aero - multiprocess not enabled.

Comment 2

3 years ago
Tracking for firefox41 given the negative user experience of unreadable browser menu.
tracking-firefox41: ? → +

Comment 3

3 years ago
Gijs, would you be able to help me find an owner for this bug? There hasn't been any activity on this once since ~2 months. Thanks!
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

3 years ago
Brian, do you have cycles to look at this?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(bgrinstead)
(Assignee)

Comment 5

3 years ago
Created attachment 8632253 [details]
deved-menu-win7-classic-light-theme.png

screenshot of the problem on the light theme
(Assignee)

Comment 6

3 years ago
It's inheriting `color: #000;` that's being set on the main window due to the lightweight theme: https://dxr.mozilla.org/mozilla-central/source/toolkit/modules/LightweightThemeConsumer.jsm#121.  For normal lightweight themes it doesn't matter because the theme's accentcolor is the background on which the menu is printed.
(Assignee)

Comment 7

3 years ago
Created attachment 8632269 [details] [diff] [review]
win7-classic-deved-menu.patch

Had to copy in some styles from browser.css, but remove the not(:-moz-lwtheme) from it.  Not sure if there is a better way to deal with stuff like this.  Relevant styles: https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser.css#122-137
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
Attachment #8632269 - Flags: review?(gijskruitbosch+bugs)
(Assignee)

Comment 8

3 years ago
Created attachment 8632270 [details]
deved-menu-win7-classic-light-theme-fixed.png

screenshot with patch applied

Comment 9

3 years ago
Comment on attachment 8632269 [details] [diff] [review]
win7-classic-deved-menu.patch

Review of attachment 8632269 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense to me.

You may want to add a note to the original CSS asking people to update this CSS as well if they change anything.
Attachment #8632269 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 10

3 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/bcd122bc666a
Whiteboard: [fixed-in-fx-team]
(Assignee)

Updated

3 years ago
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/bcd122bc666a
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 42
(Assignee)

Updated

3 years ago
Blocks: 1172716
Comment on attachment 8632269 [details] [diff] [review]
win7-classic-deved-menu.patch

Approval Request Comment
[Feature/regressing bug #]: n/a
[User impact if declined]:  Almost invisible text and toolbutton on Windows7 Classic and wrong colors in DevEdition Win 10 (since bug 1172716 depends on this patch)
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: Wrong colors
[String/UUID change made/needed]: n/a
Attachment #8632269 - Flags: approval-mozilla-aurora?
Comment on attachment 8632269 [details] [diff] [review]
win7-classic-deved-menu.patch

Approved as it's a patch with a very low risk associated and it's been in m-c for a few days.
Attachment #8632269 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Confirming this fix using the STR from the description using:
- latest Nightly, build ID: 20150722030205;
- latest Aurora, build ID: 20150722004007.
Status: RESOLVED → VERIFIED
status-firefox41: fixed → verified
status-firefox42: fixed → verified
QA Contact: cornel.ionce
You need to log in before you can comment on or make changes to this bug.