[RTL][Calendar]The heading of Google login page is truncated at wrong side in Calendar.

VERIFIED FIXED in 2.2 S13 (29may)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: mmedeiros)

Tracking

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(4 attachments)

[1.Description]:
[RTL][Flame v2.2&v3.0][Nexus 5 2.2&3.0][Calendar]The heading with long LTR text at Google login page is truncated at left side of text when user logs in a gmail account in Calendar.
See attachment:Google login page.png

[2.Testing Steps]: 
1. Set system language as Arabic.
2. Launch Calendar.
3. Tap menu -> settings -> Add Account.
4. Select Google.
5. Observe the Google login page.
6.  Input a valid Google address and password, then tap "Sign in" button.
7. Observe the login page.

[3.Expected Result]: 
5&7. The heading with long LTR text should be truncated at right side of text.

[4.Actual Result]: 
5&7. The heading with long LTR text is truncated at left side of text.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.041427
Firmware Date          Sun May 17 04:14:38 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150517010201
Gaia Revision          4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gaia Date              2015-05-15 22:18:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f6ea66057fe
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.044012
Firmware Date          Sun May 17 04:40:23 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.041034
Firmware Date          Sun May 17 04:10:50 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150517010201
Gaia Revision          4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gaia Date              2015-05-15 22:18:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f6ea66057fe
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.043539
Firmware Date          Sun May 17 04:35:55 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
QA Whiteboard: [rtl-impact]
See Also: → 1165205
Triage: P2, nominating to block
blocking-b2g: --- → 2.2?
Priority: -- → P2
Assignee: nobody → mmedeiros
Target Milestone: --- → 2.2 S13 (29may)
Attachment #8607815 - Flags: review?(gaye)
Comment on attachment 8607815 [details] [review]
[gaia] millermedeiros:1165829-rtl-google-login-header > mozilla-b2g:master

easy peasy
Attachment #8607815 - Flags: review?(gaye) → review+
https://github.com/mozilla-b2g/gaia/pull/30136

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
landed on master https://github.com/mozilla-b2g/gaia/commit/142aed0f86ac44454f640c48c6853ec510be57ee
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8607815 [details] [review]
[gaia] millermedeiros:1165829-rtl-google-login-header > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none
[User impact] if declined: truncated text on the header is confusing, specially while page is still loading
[Testing completed]: manual
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8607815 - Flags: approval-gaia-v2.2?
Posted image verify_v3.0_pass.png
This issue has been verified as pass on latest build of Flame 3.0 and Nexus 5 3.0 by STRs in comment 0.
Result:The heading with long LTR text is truncated at right side of text at Google login page.
See attachment:verify_v3.0_pass.png
Rate:0/3

Device: Flame 3.0 (pass)
Build ID               20150524160204
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150524.192425
Firmware Date          Sun May 24 19:24:36 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 3.0 (pass)
Build ID               20150524160204
Gaia Revision          5bcc08a732163087999251b523e3643db397412c
Gaia Date              2015-05-24 14:44:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b6623a27fa64
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150524.193633
Firmware Date          Sun May 24 19:36:49 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
Attachment #8607815 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
blocking-b2g: 2.2? → 2.2+
Keywords: verifyme
This Problem is verified pass on latest build of Flame 2.2 by STR in comment 0.
Actual result: The heading with long LTR text is truncated at right side of text now.
See attachment: Verify_Pass_Flame2.2.png
Rate: 0/5

Device: Flame 2.2 (Pass)
Build ID               20150527002504
Gaia Revision          8084264c4d1e28bc33220bc7443c7425bb76dbcc
Gaia Date              2015-05-27 03:47:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/19fcc06fb7ab
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.040521
Firmware Date          Wed May 27 04:05:32 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
This Problem is also verified pass on latest build of N5 2.2.
Rate: 0/5

Device: N5 2.2 (Pass)
Build ID               20150527002504
Gaia Revision          8084264c4d1e28bc33220bc7443c7425bb76dbcc
Gaia Date              2015-05-27 03:47:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/19fcc06fb7ab
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150527.034352
Firmware Date          Wed May 27 03:44:07 EDT 2015
Bootloader             HHZ12f
You need to log in before you can comment on or make changes to this bug.