[Market Custom Framework]If user opens marketplace from rocketbar, all page of the marketplace will descend about 2 lines.

VERIFIED FIXED in 2.2 S13 (29may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: xiongfuchao, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S13 (29may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [v2.2-nexus-5-l][systemsfe])

Attachments

(4 attachments)

Posted file logcat_0405.txt
[1.Description]:
[Flame v2.2][Nexus5 v3.0]When user searches an app to install, market place will open. Then they will find all pages of marketplace will descend, and about two lines at bottom of the page will be truncated.
Found time:04:05
See attachment:logcat_0405.txt & video_0405.mp4

[2.Testing Steps]: 
1.Open rocketbar and input "line".
2.Tap install line and select Marketplace.
3.Slide to bottom of the page and check.
4.Open ":debug" page.
5.Open Region Override selector and check.

[3.Expected Result]: 
3.All page shows completely.
5.The ok button shows completely.

[4.Actual Result]: 
3.About two lines at bottom of the page will be truncated.
5.OK button will be truncated.

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.041427
Firmware Date          Sun May 17 04:14:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Unaffected):
Build ID               20150517010201
Gaia Revision          4c0f36e9dfe017bf2a698d416a57c8156b43383d
Gaia Date              2015-05-15 22:18:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f6ea66057fe
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.044012
Firmware Date          Sun May 17 04:40:23 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 version(Affected):
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.041034
Firmware Date          Sun May 17 04:10:50 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0 version(Unaffected):
Build ID               20150517160201
Gaia Revision          afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gaia Date              2015-05-17 03:33:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/35918b0441b4
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150517.194053
Firmware Date          Sun May 17 19:41:09 EDT 2015
Bootloader             HHZ12f


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This phenomenon is more obvious on Nexus5, and the OK button is not shown.
(Reporter)

Comment 1

4 years ago
Posted video video_0405.mp4
(Reporter)

Comment 2

4 years ago
I'm sorry for describe error,the issue just be found in Flame2.2 and nexus5 2.2.
Flags: needinfo?(hcheng)
is this bug a regression?
Flags: needinfo?(hcheng)
Keywords: qawanted
This looks like a software home button issue to me, and has basic functionality broken. Nominating for 2.2. Can we also get a reverse regression window to see which bug fixed this in master?
blocking-b2g: --- → 2.2?
Component: Gaia::Everything.me → Gaia::System::Window Mgmt
Whiteboard: [v2.2-nexus-5-l] → [v2.2-nexus-5-l][systemsfe]
This issue DOES reproduce on 3.0 as well.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150518010206
Gaia: afea16de7a76c3b6d15c35fb4c37bac71c8ddc6a
Gecko: 35918b0441b4
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
QA Contact: jmercado
The change for Bug 1088352 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141103162318
Gaia: 73eeaa23172c26e732972c318ea6aab20e0e1cae
Gecko: 9247b220e595
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141103170717
Gaia: 1f621c11282161cc47870ab2c8d046103270dc71
Gecko: f45f23c52b34
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 73eeaa23172c26e732972c318ea6aab20e0e1cae
Gecko: f45f23c52b34

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 1f621c11282161cc47870ab2c8d046103270dc71
Gecko: 9247b220e595

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/73eeaa23172c26e732972c318ea6aab20e0e1cae...1f621c11282161cc47870ab2c8d046103270dc71
Blocks: 1088352
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kevin, can you take a look at this please? This might have been caused by the work done for bug 1088352.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kgrandon)
Summary: [Market Custom Framework]If user opens marketpalce from rocketbar, all page of the market palece will descend about 2 lines. → [Market Custom Framework]If user opens marketplace from rocketbar, all page of the marketplace will descend about 2 lines.
blocking-b2g: 2.2? → 2.2+
I am currently unable to reproduce on 3.0. Could we have a retest done here? I have a feeling that it might be a marketplace bug, and not necessarily a gaia one. It could've been fixed since the bug was opened.
Flags: needinfo?(kgrandon)
Keywords: qawanted
This issue occurs on today's 3.0 and 2.2 following the steps as written in comment 0.

Issue DOES occur

Environmental Variables:
Device: Flame 3.0
BuildID: 20150520065444
Gaia: b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gecko: 8d8df22fe72d
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150520081845
Gaia: 04f587bfa0f2c438816e6172ccdf56ad5211725b
Gecko: 4e7de0a4ff09
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Issue does NOT occur

Environmental Variables:
Device: Flame 2.1
BuildID: 20150520082146
Gaia: c80865cb0bf73f1b97defbc646083b404feb3ac4
Gecko: ddb03c402946
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee: nobody → kgrandon
I am unfortunately unable to reproduce this issue, so I don't feel so effective here. I'll also be at a conference next week, so not sure if I will be able to get to it. Unassigning from myself for now, but will pick this up in a week or so if it's still available.

Chris or Ben - could either of you guys take a look at this and see if you can reproduce?
Assignee: kgrandon → nobody
Flags: needinfo?(chrislord.net)
Flags: needinfo?(bfrancis)
Alberto, can you take a look here?
Flags: needinfo?(apastor)
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8611178 [details] [review]
[gaia] albertopq:1165849-marketplace-rocketbar2 > mozilla-b2g:master

I think bug 1088352 is no longer valid in 2.2 and master (since we changed the way we display search results) so we can remove these lines, which are causing the regression. Kevin?
Attachment #8611178 - Flags: review?(kgrandon)
Comment on attachment 8611178 [details] [review]
[gaia] albertopq:1165849-marketplace-rocketbar2 > mozilla-b2g:master

These lines were *not* dependent on the way that we display search results, but instead were implemented due to the activity window being displayed at the wrong height.

I don't think that this patch is correct, but it probably won't break anything for the time being since we've removed the old web result provider. I wasn't able to reproduce, but since you can, I'm fine giving this a shot. Thanks!
Attachment #8611178 - Flags: review?(kgrandon) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/30257

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Trees seem to be back open now, let's try this again.
Keywords: checkin-needed
Flags: needinfo?(chrislord.net)
Flags: needinfo?(bfrancis)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S13 (29may)
Per Comment 17,this bug has been landed and fixed on master.


This bug has been verified as pass on latest Nightly build of Flame v3.0 and Nexus 5 v3.0 by the STR in Comment 0.

Actual results: Both the text contents and buttons at the bottom of Marketpalce page show completely after searching form Rocketbar.
See attachment: verified_v3.0.mp4
Reproduce rate: 0/6

---------------------------------------------------------------------------
Device: Flame v3.0 build(Pass)
Build ID               20150528160205
Gaia Revision          e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gaia Date              2015-05-28 10:47:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f986e55c4e0b
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150528.192335
Firmware Date          Thu May 28 19:23:44 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v3.0 build(Pass)
Build ID               20150528002504
Gaia Revision          999bc627063d16c20f703e702f31a5cf0da8b4a6
Gaia Date              2015-05-28 02:16:40
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/351101ec82ba
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150528.040306
Firmware Date          Thu May 28 04:03:25 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Comment hidden (obsolete)
Please ignore the Nexus 5 v3.0 version in Comment 18, updated as:

Build ID               20150528160205
Gaia Revision          e7d268074ee3c9eeb191c2205c0e35992fb3915d
Gaia Date              2015-05-28 10:47:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f986e55c4e0b
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150528.191717
Firmware Date          Thu May 28 19:17:35 EDT 2015
Bootloader             HHZ12f
@Alberto, could you uplift to v2.2?
Flags: needinfo?(apastor)
(Assignee)

Comment 23

4 years ago
Comment on attachment 8611178 [details] [review]
[gaia] albertopq:1165849-marketplace-rocketbar2 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1088352
[User impact] if declined: Height not calculated correctly when opening an app from the rocketbar
[Testing completed]: Manual testing. We are removing code that is no longer valid. I'm not sure it makes sense to add a test that checks that we don't do something we shouldn't.
[Risk to taking this patch] (and alternatives if risky): It just removes code for an specific case (opening a window from the rocketbar) that is no longer valid, as the use case for that code is not valid anymore.
[String changes made]: none
Flags: needinfo?(apastor)
Attachment #8611178 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8611178 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Approving and requesting QA verify when patch landed 2.2
Keywords: verifyme
Shally, could you please help verify 2.2?
Flags: needinfo?(lixia)
This bug has been verified as pass on latest Nightly build of Flame v2.2 and Nexus 5 v2.2 by the STR in Comment 0.

Actual results: Both the text contents and buttons at the bottom of Marketpalce page show completely after searching form Rocketbar.
See above attachment: verified_v3.0.mp4
Reproduce rate: 0/6


Device: Flame v2.2 build(Pass)
Build ID               20150604002503
Gaia Revision          b96e657ce2822df5da5da1a8ba91c38ad3281bc9
Gaia Date              2015-06-04 05:59:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/273f8ee45c88
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150604.102004
Firmware Date          Thu Jun  4 10:20:13 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 v2.2 build(Pass)
Build ID               20150604162503
Gaia Revision          8fc797527a3eca7665bc1d1828848f2fb77ca99f
Gaia Date              2015-06-04 07:46:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f2157a04d75b
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150604.195634
Firmware Date          Thu Jun  4 19:56:49 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
Flags: needinfo?(lixia)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.