Closed Bug 1088352 Opened 7 years ago Closed 7 years ago

[SHB][Bookmark] The keyboard overlaps the text field when trying to edit a bookmark name

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S8 (7Nov)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: cnelson, Assigned: kgrandon)

References

()

Details

(Keywords: regression, Whiteboard: [systemsfe][2.1-Exploratory-3][shb-enabled])

Attachments

(2 files)

3.75 KB, text/plain
Details
46 bytes, text/x-github-pull-request
alive
: review+
Details | Review
Attached file log.txt
When the user is adding a bookmark to the homescreen, they will be able to edit the name of the bookmark.  Once the user selects the text field, the keyboard will overlap the text field.  This prevents the user from seeing what they are writing, as well as pressing the "x" button to clear the text field.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141023001201
2) Type a few letters into the search/rocket bar to find results.
3) Select and hold on one of the results.
4) Choose to add to homescreen.
5) Tap the text field, which will bring up the keyboard.
6. Notice the keyboard overlaps the text field.
  
Actual:
The keyboard overlaps the text field when editing the name of a bookmark.
  
Expected: 
The keyboard doesn't overlap the text field.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  

Repro frequency: 100%
See attached: Logcat, video clip https://www.youtube.com/watch?v=Tj9Sl84Wu90
Flags: needinfo?(dharris)
This issue does occur on Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)

The keyboard overlaps the text field when editing the name of a bookmark.

Flame 2.2 

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141023040204
Gaia: 27a1d1baaa8e375b70e043efee67d5f2206c330b
Gecko: 88adcf8fef83
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

This issue doesn't occur on Flame 2.0 (319mb)(Kitkat Base)(Full Flash)

The keyboard doesn't overlap the text field.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
Build ID: 20141023001201
Gaia: 1e48e3e40e0780c0cd07a3457e5fe2efeeb542d1
Gecko: 09fb60a37850
Version: 34.0 (2.1)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Whiteboard: [2.1-Exploratory-3] → [2.1-Exploratory-3][shb-enabled]
It should be noted that this issue only occurs when the SHB is enabled.
[Blocking Requested - why for this release]:

nominating this to block 2.1. The user should be able to see what they are typing when renaming a bookmarked webpage on the homescreen. Also this is a regression
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20140916155959
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 543f57ab6a44
Platform Version: 35.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken
BuildID: 20140916162300
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 49ef7b18963d
Platform Version: 35.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Working Gaia / Broken Gecko = No repro
Gaia: e2d70bee03b5380ac327a145e5d694fb2443f018
Gecko: 49ef7b18963d
Broken Gaia / Working Gecko = Repro
Gaia: 50666fa8bbbf3d346faff24f92ad8140a44a49d0
Gecko: 543f57ab6a44
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e2d70bee03b5380ac327a145e5d694fb2443f018...50666fa8bbbf3d346faff24f92ad8140a44a49d0


B2G Inbound
Last working
BuildID: 20140916123756
Gaia: d3510be2067ff39ce07e72268ae510279ee7688e
Gecko: 6b7ab2f8fc1f
Platform Version: 35.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First broken
BuildID: 20140916131125
Gaia: ea06ae56236a06322d8dfe8dd1488b09293dd571
Gecko: fa0dc2128441
Platform Version: 35.0a1
Firmware Version: V188
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Working Gaia / Broken Gecko = No repro
Gaia: d3510be2067ff39ce07e72268ae510279ee7688e
Gecko: fa0dc2128441
Broken Gaia / Working Gecko = Repro
Gaia: ea06ae56236a06322d8dfe8dd1488b09293dd571
Gecko: 6b7ab2f8fc1f
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/d3510be2067ff39ce07e72268ae510279ee7688e...ea06ae56236a06322d8dfe8dd1488b09293dd571
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
broken by Bug 1066206 - Can you take a look Kevin?
Blocks: 1066206
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(kgrandon)
QA Contact: ckreinbring
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(kgrandon)
Whiteboard: [2.1-Exploratory-3][shb-enabled] → [systemsfe][2.1-Exploratory-3][shb-enabled]
Blocks: 1077579
Summary: [Bookmark] The keyboard overlaps the text field when trying to edit a bookmark name → [SHB][Bookmark] The keyboard overlaps the text field when trying to edit a bookmark name
Component: Gaia::Bookmark → Gaia::System::Window Mgmt
Attached file WIP - Pull request
Comment on attachment 8514714 [details] [review]
WIP - Pull request

Alive - this works, but doesn't feel so good. Can you think of any better ways to do this?
Attachment #8514714 - Flags: review?(alive)
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Target Milestone: --- → 2.1 S8 (7Nov)
Comment on attachment 8514714 [details] [review]
WIP - Pull request

Note: If the part in app window is to prevent statusbar to show in bookmark activity, then this is contractary to bug https://bugzilla.mozilla.org/show_bug.cgi?id=1088723 unless bookmark activity is designed as fullscreen.
Attachment #8514714 - Flags: review?(alive) → review+
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #8)
> Comment on attachment 8514714 [details] [review]
> WIP - Pull request
> 
> Note: If the part in app window is to prevent statusbar to show in bookmark
> activity, then this is contractary to bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=1088723 unless bookmark
> activity is designed as fullscreen.

Yeah, it's slightly different in the fact that we currently do not show the statusbar for rocketbar, or apps opened within rocketbar. I think we should probably do some fullscreen consolidation work between rocketbar windows, so they behave the same as normal fullscreen apps. 

I'll try to add a simple unit test as well and get this landed.
In master: https://github.com/mozilla-b2g/gaia/commit/29a00a51773a7cc3b6f89d9aaeb50b9effae23e1
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8514714 [details] [review]
WIP - Pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 2.1 feature implementation
[User impact] if declined: Poor experience when saving links to home screen from search app.
[Testing completed]: Manual and integration tests.
[Risk to taking this patch] (and alternatives if risky): Relatively low risk, we've tried to scope this to only this case.
[String changes made]: None.
Attachment #8514714 - Flags: approval-gaia-v2.1?(bbajaj)
Attachment #8514714 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Issue verified fixed on Flame 2.1 and Flame 2.2

Actual Results: Keyboard opening on the edit bookmark name scrolls the text field so that it is not overlapping keyboard.

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141105001204
Gaia: 154da5e17029a51002d5d9b7df39563d509edde6
Gecko: 3b0c3580a58d
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2(319mb)(KitKat)(Shallow Flash)
BuildID: 20141105040206
Gaia: 7c9e7cabbde941b976e0e40a3a1d94e21aa9c5e9
Gecko: 62990ec7ad78
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
In comment 13 the Flame 2.1 environmental variables are incorrect. Should be:

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141105001204
Gaia: 1ca22badfae2f9ce066c2405af3e85c4e2d5d380
Gecko: 3b0c3580a58d
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.