Closed Bug 11660 Opened 21 years ago Closed 20 years ago

Clip should apply to child views

Categories

(Core :: Web Painting, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: troy, Assigned: kmcclusk)

References

Details

(Keywords: css2)

Attachments

(2 files)

The "clip" that can be specified for a view should apply to the child views,
i.e. those child views outside of the clip rect should be clipped

The clip rect is optional, because it's usage by layout depends on the
'overflow' property. The default value is 'visible' which means that child
elements that extend outside their parent are visible. A value of 'hidden' means
that child elements that extend outside the parent are clipped
Priority: P3 → P2
Blocks: 10915
Status: NEW → ASSIGNED
Target Milestone: M10
Target Milestone: M10 → M11
Target Milestone: M11 → M12
This is a feature bug. Probably not urgent, given that bug #10915 is in M13.
Deferring to M12.
QA Contact: beppe → paulmac
Target Milestone: M12 → M13
On the other hand, child views may always be getting clipped to parent views by
the compositor. This should only happen if a clip rect is specified?
Yes, clipping of child views should only happen if a clip rect is specified. If
no clip rect is specified, then the child views should be allowed to extend
outside of their parent and they should be visible and paint and get events

We rely on this behavior in layout, because that's the way CSS2 visibility works
Target Milestone: M13 → M15
*** Bug 27602 has been marked as a duplicate of this bug. ***
*** Bug 27735 has been marked as a duplicate of this bug. ***
So a container is not a container by default?
This will break a million pages.
A parent-container SHOULD clip it childern BY DEFAULT.
Otherwise, there is precious little point to it's parent status.
A container should "contain" - rather than simply be loosly associated with - 
it's children.
*** Bug 27602 has been marked as a duplicate of this bug. ***
Here's the right way to fix this:  we need to build a more persistent display 
list, that we keep around, which caches clipping calculations, etc. We don't want 
to have to recompute this each time we draw.
*** Bug 30975 has been marked as a duplicate of this bug. ***
*** Bug 30974 has been marked as a duplicate of this bug. ***
This requires a tree walk over children when nsView::SetClip() is called. To do 
this efficiently will take some thought.
Assignee: beard → kmcclusk
Status: ASSIGNED → NEW
QA Contact: paulmac → petersen
Keywords: css2
Status: NEW → ASSIGNED
Bulk moving to M16
Target Milestone: M15 → M16
Fixed in 4/13/2000 5:02 PM build.
Filed bug 35791 to cover the case where the view has a widget.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
QA Contact: petersen → chrisd
As per meeting with ChrisD yesterday, taking QA.
QA Contact: chrisd → py8ieh=bugzilla
VERIFIED on Win2K Comm M18 trunk builds 2000090609 using testcase.

Mac and Windows don't work well with clip. See bug 51678.
Status: RESOLVED → VERIFIED
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.