Attachment icon of Thread pane does not appear when some messages are viewed("pdf under multipart/mixed under multipart/alternative" is shown as-if attachment at Attachment box)

UNCONFIRMED
Unassigned

Status

Thunderbird
Folder and Message Lists
--
major
UNCONFIRMED
3 years ago
a year ago

People

(Reporter: Konstantin Svist, Unassigned)

Tracking

31 Branch
Unspecified
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8607220 [details]
Screenshot - 05182015 - 02:20:11 PM.png

To reproduce:
Received a message with a few PDF attachments.

Actual results:
I can see attachments when I look at the email in the Message Pane, but there's no corresponding icon in the Attachments column in the message list.
When I filter view by "Has Attachments" the message in question is not included!

Expected results:
I should be able to see which messages have attachments and expect to find them with the appropriate view filter


Additional info:
If I open the message explicitly (not just in Message Pane), the attachment status is updated to correct value.
If I then "Repair" the folder, attachment status is reset to the problematic status


Setting Severity to major since messages appear lost to the user

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 953315
Reopen per bug 953315 comment #11 and bug 953315 comment #12.

Mail structure provided by bug opener of this bug at bug 953315 comment #10.
> Content-Type: multipart/alternative; boundary=Apple-Mail-8--745298500
>    --Apple-Mail-8--745298500
>    Content-Type: text/plain; charset=windows-1252
>    --Apple-Mail-8--745298500
>    Content-Type: multipart/mixed; boundary=Apple-Mail-9--745298500
>       --Apple-Mail-9--745298500
>       Content-Type: text/html; charset=us-ascii
>       --Apple-Mail-9--745298500
>       Content-Disposition: inline; filename="2015-02-01 [***] Minutes.pdf"
>       Content-Type: application/pdf;
>       --Apple-Mail-9--745298500
>       Content-Transfer-Encoding: quoted-printable
>       Content-Type: text/html; charset=windows-1252

It looks for me following.
1. multipart/alternative => text/plain is used as "message body part under multipart/alternative".
   And, multipart/mixed under multipart/alternative != usable part such as text/plain, text/html under multipart/alternative.
   So, it should be completely ignored, because text/plain part is already chosen in multipart/alternative.
2. However, it's multipart/mixed, then "application/pdf part under multipart/mixed under multipart/alternative"
   is shown as-if attachment at attachment box, because it's non-used/non-displayable sub part.
   If such PDF part is shown as-if attachment, I believe text/html part also should be shown as-if attachment.

Or, it may be:
3. "multipart/mixed under multipart/alternative" is treated like multipart/related because text/html is contained.
4. text/html in "multipart/mixed under multipart/alternative" is treated as "message body"
5. PDF part in "multipart/mixed under multipart/alternative" is shown as-if attachment because non-displayable.
6. Because it's not "non-used sub part under multipart/related", "attachment icon" is not shown at Thread pane.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Attachment status does on appear for some messages → Attachment icon of Thread pane does not appear when some messages are viewed("pdf under multipart/mixed under multipart/alternative" is shown as-if attachment at Attachment box)
It's hard for me to say "malformed mail" in this case.

Interpretation of multipart/mixed depends on people, mailer, mail application etc.
(1) Traditional use(or old definition) :
    message body(text) + attachments
(2) Current definition by RFC :
    Show content in order placed under multipart/mixed,
    with respecting Content-Disposition:inline/attachment requested by mail sender.
    There is no "message body" concept in this case.

I think (2) is better applied on "multipart/mixed under multipart/alternative", at least when text/plain and/or text/html is contained in the "multipart/mixed under multipart/alternative".

When provided mail structure, I think following is valid procedure.
1. Because text/html is contained, accept the multipart/mixed as "Thunderbird can display it" part in multipart/alternative.
2. Because multipart/alternative, choose the multipart/mixed which is located at bottom(highest preference of sender).
3. Show sub parts in the multipart/mixed in order placed in the multipart/mixed,
   with respecting Content-Disposition:inline/attachment requested by mail sender.
4. Because PDF is non-displayable part, show it in Attachment box, as "valid attached file to mail".

Updated

a year ago
Component: Untriaged → Folder and Message Lists
You need to log in before you can comment on or make changes to this bug.