Missing Pocket icon in reader view mode

VERIFIED FIXED in Firefox 38.0.5

Status

()

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: petruta.rasa, Assigned: jaws)

Tracking

38 Branch
Firefox 38
All
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38.0.5 verified, firefox39 fixed, firefox40 unaffected, firefox41 unaffected)

Details

Attachments

(1 attachment)

Reproducible with Firefox 38.0.5 beta 3 under Win 7 (x64) and Ubuntu 14.04 (x64).
Not reproducible with:
 Firefox 38.0.5 beta 3 under Mac OS X 10.9.5.
 latest Aurora 40.0a2 2015-05-18 after enabling Pocket
 latest Nightly 41.0a1 2015-05-18

Steps to reproduce:
1. Open an article that can be viewed in Reader Mode (eg http://edition.cnn.com/2015/05/19/africa/cameroon-cinema-revival/index.html)
2. Select the Reader View icon in location bar

Actual results:
The Pocket icon from the left menu is blank. The button can be clicked and used, but has no icon on it: http://i.imgur.com/VzC67hn.png

Expected results:
The Pocket icon is displayed for all platforms.
It actually seems that something went wrong in Bug 1155517 - the Pocket icon is missing from Reader View on both 38.0.5b2 and 38.0.5b3. Please not that this happens _only_ on Windows, tested with Windows 7 (x64), Windows 7 (x86), Windows 8.1 (x64).
Flags: qe-verify+
OS: All → Windows
Posted patch PatchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: pocket
[User impact if declined]: missing pocket icon in reader mode for majority of windows users (button with no icon)
[Describe test coverage new/current, TreeHerder]: manual QA testing
[Risks and why]: very low risk, file was not added to separate manifest section
[String/UUID change made/needed]: none
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8607556 - Flags: review?(dolske)
Attachment #8607556 - Flags: approval-mozilla-release?
Attachment #8607556 - Flags: approval-mozilla-beta?
Comment on attachment 8607556 [details] [diff] [review]
Patch

Or Gijs if he can get to the review sooner than dolske due to timezones.
Attachment #8607556 - Flags: review?(gijskruitbosch+bugs)

Updated

4 years ago
Attachment #8607556 - Flags: review?(gijskruitbosch+bugs)
Attachment #8607556 - Flags: review?(dolske)
Attachment #8607556 - Flags: review+
Attachment #8607556 - Flags: approval-mozilla-release?
Attachment #8607556 - Flags: approval-mozilla-release+
Attachment #8607556 - Flags: approval-mozilla-beta?
Attachment #8607556 - Flags: approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
Verified fixed on RC 38.0.5-build3 (20150521175336), using Windows 7 (x64) and Windows 8.1 (x86). Also made sure that button still looks and works as expected on Mac OS X 10.9.5 and Ubuntu 14.04 (x64).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
QA Contact: andrei.vaida
You need to log in before you can comment on or make changes to this bug.