Change Reader View to have a "Save Page to Pocket" button instead of "Add To Reader List"

VERIFIED FIXED in Firefox 38.0.5

Status

()

Toolkit
Reader Mode
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Dolske, Assigned: jaws)

Tracking

unspecified
mozilla41
Points:
2
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox38.0.5 verified, firefox39 fixed, firefox40 fixed, firefox41 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
When viewing a page in Reader View, the user should have a button (in the Reader View toolbar) to "Save To Pocket" (wording TBD).

This will replace the "Add To Reading List" button on Desktop. Current plan is for Android to keep the long-existing Reading List button/feature, although we're still figuring out what Pocket integration means on Android.

If the user isn't signed in to Pocket, this should probably offer to create an FxA / signin, as with the toolbar button?
(Reporter)

Updated

3 years ago
Blocks: 1155467

Updated

3 years ago
Flags: qe-verify?
Flags: firefox-backlog+
(In reply to Justin Dolske [:Dolske] from comment #0)
> If the user isn't signed in to Pocket, this should probably offer to create
> an FxA / signin, as with the toolbar button?

@mmaslaney: similarly, should we hide this button when a user isn't logged in?
Flags: needinfo?(mmaslaney)
That, or we could have the button disabled accompanied by a tooltip encouraging you to create an account? 

In the spirit of shipping by June, let's suppress the feature if the user is not signed in, unless you feel like the previously mentioned is possible within our tight deadline.
Flags: needinfo?(mmaslaney) → needinfo?(clarkbw)
We can continue to investigate other avenues for a short period of time, likely end of this week is the hard stop.  Suppress the feature seems to be the easiest way right now.
Flags: needinfo?(clarkbw)
note this work is being done in bug 1155523
Flags: qe-verify? → qe-verify+
QA Contact: andrei.vaida
Most of this work was completed in bug 1155523, but this bug will need to add the icon and string for the button. It is currently naked.
Created attachment 8598100 [details]
Pocket_ReaderView.zip

Jared, do these work out?
Flags: needinfo?(jaws)
(In reply to Michael Maslaney [:mmaslaney] (mmaslaney@mozilla.com) from comment #6)
> Jared, do these work out?

I think so, thanks!
Flags: needinfo?(jaws)
(Reporter)

Updated

3 years ago
Priority: -- → P2
Created attachment 8604842 [details] [diff] [review]
Patch
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8604842 - Flags: review?(dolske)

Updated

3 years ago
Iteration: --- → 41.1 - May 25
(Reporter)

Updated

3 years ago
Attachment #8604842 - Flags: review?(dolske) → review+
Comment hidden (obsolete, typo)
Approval Request Comment
[Feature/regressing bug #]: pocket
[User impact if declined]: the button to add to pocket from reader mode is blank
[Describe test coverage new/current, TreeHerder]: none, just adding a graphic
[Risks and why]: none
[String/UUID change made/needed]: none
https://hg.mozilla.org/mozilla-central/rev/d06d16029cad
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1164570
(Reporter)

Comment 14

3 years ago
Comment on attachment 8604842 [details] [diff] [review]
Patch

a+ for aurora/beta/release: required for Pocket launch in 38.0.5.
Attachment #8604842 - Flags: approval-mozilla-release?
Attachment #8604842 - Flags: approval-mozilla-release+
Attachment #8604842 - Flags: approval-mozilla-beta?
Attachment #8604842 - Flags: approval-mozilla-beta+
Attachment #8604842 - Flags: approval-mozilla-aurora?
Attachment #8604842 - Flags: approval-mozilla-aurora+
(Reporter)

Comment 15

3 years ago
(aurora currently closed)
https://hg.mozilla.org/releases/mozilla-beta/rev/87d07b3f416e
https://hg.mozilla.org/releases/mozilla-release/rev/921eb304600e
status-firefox38.0.5: --- → fixed
status-firefox39: --- → fixed
status-firefox40: --- → affected
Verified fixed on 38.0.5b2-build1 (20150514163436), using Ubuntu 14.04 (x64), Windows 7 (x64) and Mac OS X 10.9.5.

* The Pocket button available in Reader View brings up the sign-up panel if the user is not logged into Pocket.
* Clicking the Pocket button available in Reader View successfully saves the page to Pocket.
* If the Pocket add-on is already installed and used by default instead of the built-in one, Reader View will also hide the Pocket button from its controls bar.
* The Pocket button adapts properly to browser window and screen size, display resolution and zoom level.

The only thing that *might* be missing here is the button's tooltip.
Status: RESOLVED → VERIFIED
status-firefox38.0.5: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.