[Metrics] Record reflows on per app basis

RESOLVED DUPLICATE of bug 1183101

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1183101
3 years ago
3 years ago

People

(Reporter: thills, Assigned: russn)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.5+)

Details

(Reporter)

Description

3 years ago
We need to record the reflows on a per app basis for architecture validation purposes.  This would be stored as a histogram and delivered as a ping to the Telemetry Server.
(Reporter)

Updated

3 years ago
Blocks: 1152000
(Assignee)

Comment 1

3 years ago
Jan, how much work would do you think it would be to track reflows per context/frame?
Flags: needinfo?(janx)

Comment 2

3 years ago
(I'll have a better reply soon, see also https://bugzilla.mozilla.org/show_bug.cgi?id=1166286#c2)

Comment 3

3 years ago
Referring to the bug title, tracking reflows per app is already something the HUD can do, so it will be pretty easy (with bug 1166295) to feed that data to Telemetry.

It might be possible to get a more precise origin for a reflow. I imagine we hear about reflows from a particular renderer, so the console devtools actor that listens for reflows could in theory also tell which renderer performed a particular reflow.

Per-app (actually per-frame, or better per-top-level-content) measurements is something that the HUD already knows how to do, so maybe let's do that for now. For the Telemetry metrics where it's really important to know from which precise context (e.g. from which worker or iframe inside that top-level-content) an event was triggered, let's file bugs to make the associated devtools actor context-aware.

I can help with the bug filing, because I know which devtools actor is responsible for which HUD metric.
Flags: needinfo?(janx)
(Assignee)

Updated

3 years ago
Assignee: nobody → rnicoletti
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Depends on: 1178512
Blocks: 1180699
feature-b2g: --- → 2.5+
(Reporter)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183101
You need to log in before you can comment on or make changes to this bug.