[music] Move audio playback to the "backend"

RESOLVED FIXED in FxOS-S4 (07Aug)

Status

Firefox OS
Gaia::Music
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: squib, Assigned: squib)

Tracking

unspecified
FxOS-S4 (07Aug)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
As part of the music player refactoring, we'd like to move the audio playback and all of the other related code into the "backend" (read: a separate iframe). This includes the actual <audio> element, remote control handling (bluetooth and lockscreen/tray), and playlist advancement. The UI will then send/receive messages from the playback backend.

Updated

3 years ago
Target Milestone: --- → FxOS-S3 (24Jul)
Created attachment 8636275 [details] [review]
[gaia] jimporter:music-player-cleanup > mozilla-b2g:master

Updated

3 years ago
Target Milestone: FxOS-S3 (24Jul) → FxOS-S4 (07Aug)
(Assignee)

Updated

3 years ago
Attachment #8636275 - Flags: review?(jdarcangelo)
Comment on attachment 8636275 [details] [review]
[gaia] jimporter:music-player-cleanup > mozilla-b2g:master

Nice work man! Looks great! I left a few minor nits/comments on the PR for you to look at.
Attachment #8636275 - Flags: review?(jdarcangelo) → review+
(Assignee)

Comment 3

3 years ago
Landed: https://github.com/mozilla-b2g/gaia/commit/d2c91b0663f2f2e3dc28d2e1e21e8a0a654398cc
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Kevin - since this is resolved, could you do a check on the music app for any regressions?  According to Jim, there is a fundamental change in how the playback queues are being handled, so perhaps we could try out how it handles multiple music files.   I'll check it out as well.
Flags: needinfo?(ktucker)
(Assignee)

Updated

3 years ago
Depends on: 1192710
Adding qawanted to thoroughly test around any areas that could be affected by this landing. See Comment 4.
Flags: needinfo?(ktucker)
Keywords: qawanted
I spent some time listening to mp3, mp3 320, m4a and flac files on both the Aries and Flame devices with no unexpected errors.  While listening to the files I used headphones/no headphones, interrupted the songs with calls and radio (on flame), and let the albums play in completely.

Note: Bug 1193498 has been written about downloaded mp3 files from the browser not being recognized, but I'm not sure if that would be related to the changes that have been made here.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150811030209
Gaia: 9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gecko: 8cba870a352c
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150811155235
Gaia: 2d7f369fd923b6df3b00d76844c413c1202c04ba
Gecko: 38c1ea9ccae31700630f1fe0d651e94c0c5b9e1d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

3 years ago
Depends on: 1193498
You need to log in before you can comment on or make changes to this bug.