If the Pocket button is hidden, all the Pocket-related context menu options are hidden as well

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: avaida, Unassigned)

Tracking

38 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38.0.5 affected)

Details

Reproducible on:
Beta 38.0.5b3-build1 (20150518141916)

Affected platforms:
Window 7 (x64), Mac OS X 10.9.5, Ubuntu 14.04 (x64)

Preconditions:
* user is logged into Pocket

Steps to reproduce:
1. Click menu [≡] → Customize.
2. Drag & drop the Pocket button from the toolbar (default location) to the "Additional Tools and Features" section from the Customize window → click [Exit Customize].
3. Open a page containing hyperlinks.
4. Right-click on any of the hyperlinks and check the available options.

Expected result:
* Hiding the Pocket button does NOT disable/hide the feature.
* If the Pocket button is hidden, the "Save Link to Pocket" context menu is still visible and displayed for eligible hyperlinks.
* If the user clicks the "Save Link to Pocket" context menu option while the Pocket button is hidden, a Pocket confirmation panel is still displayed stating the the link was saved to Pocket.

Actual result:
* Hiding the Pocket button causes all the related context menu options to be also hidden.
* However, the "Save page to Pocket" button from Reader View -for example- is still available, so the feature is not fully disabled/hidden by this scenario.
I believe this is expected behavior, as it's the way users can disable it if they choose too. :clarkbw, can opine.
Flags: needinfo?(clarkbw)
(In reply to Andrei Vaida, QA [:avaida] from comment #0)
> Expected result:
> * Hiding the Pocket button does NOT disable/hide the feature.

This is the intended behavior.  Hiding the button from the toolbar should remove it from all other UI hooks.

> Actual result:
> * However, the "Save page to Pocket" button from Reader View -for example-
> is still available, so the feature is not fully disabled/hidden by this
> scenario.

The reader Reader View button isn't dynamic, if you exit RV and come back the button should be gone.  We might want to file a bug for this.
Flags: needinfo?(clarkbw)
Filed bug 1167328 for the bit comment 2 talks about, but otherwise this issue filed here is working as expected.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.