If the Pocket button is hidden, there's no visual feedback displayed for clicking the save button from Reader View

RESOLVED WORKSFORME

Status

()

Firefox
Pocket
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: avaida, Unassigned)

Tracking

38 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reproducible on:
Beta 38.0.5b3-build1 (20150518141916)

Affected platforms:
Window 7 (x64), Mac OS X 10.9.5, Ubuntu 14.04 (x64)

Preconditions:
* user is logged into Pocket
* Reader View is enabled

Steps to reproduce:
1. Click menu [≡] → Customize.
2. Drag & drop the Pocket button from the toolbar (default location) to the "Additional Tools and Features" section from the Customize window → click [Exit Customize].
3. Open a Reader View-compatible page, e.g. http://www.bbc.com/autos/story/20150519-what-is-the-best-car-to-drive-around-the-world
4. Click the [Enter Reader View] button from the Location Bar.
5. From Reader View's controls bar, click the Pocket button.

Expected result:
* Hiding the Pocket button does NOT disable/hide the feature.
* If the user clicks the save button from Reader View while the Pocket button is hidden, a Pocket confirmation panel is displayed stating the the page was saved to Pocket.

Actual result:
* Clicking the button has no visual feedback.
* Looking through the Network logs, there are also no save request sent to Pocket.
I can't reproduce this -- when the main Pocket button is removed from UI, the RV button is also removed.

Perhaps you were hitting the case bug 1167328 describes? We only check the main Pocket button visibility when RV first opens.
Flags: needinfo?(andrei.vaida)
(In reply to Justin Dolske [:Dolske] from comment #1)
> I can't reproduce this -- when the main Pocket button is removed from UI,
> the RV button is also removed.
> 
> Perhaps you were hitting the case bug 1167328 describes? We only check the
> main Pocket button visibility when RV first opens.

This is indeed no longer reproducible as of RC 38.0.5-build3 (20150521175336) and RC 38.0.5-build4 (20150525141253). Closing.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38.0.5: affected → ---
Flags: needinfo?(andrei.vaida)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.