SVG systemLanguage switch with allowReorder does not work in HTML 5

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: amelia.bellamy.royds, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

Compare the following pages:

SVG file: http://upload.wikimedia.org/wikipedia/commons/e/e1/SystemLanguage.svg

Same code as inline HTML in a JSFiddle: http://fiddle.jshell.net/q56sj6kg/

If they look the same, play around with your preferred content language settings & reload.


Actual results:

The language switch in the SVG file respects the "allowReorder" attribute, and selects the user's preferred language if it is available.

The language switch in the HTML file always uses the first option that matches *any* of the users' content languages, regardless of whether the "allowReorder" attribute is included.


Expected results:

Both SVGs should have the same behavior.

Updated

4 years ago
Component: Untriaged → SVG
Product: Firefox → Core
This is not currently a valid bug as we're following the html parser specification. The html parser should be changed to support it (i.e. allowReorder being camel cased should not be lowercased in SVG)

This is a html parser issue. Changing the parser to support this should be accompanied with a corresponding spec change on https://www.w3.org/Bugs/Public

I assume you can raise a html spec bug and report back on its progress Amelia.
Flags: needinfo?(amelia.bellamy.royds)
(Reporter)

Comment 2

4 years ago
OK, to recap the problem: the HTML parser automatically lowercases the attribute, but Firefox's SVG switching code only looks for the canonical mixed-case version.

To Do for me:

* Get allowReorder in the SVG 2 specs.
* Get allowReorder in the mixed-case tag list for the HTML parser.

I don't think I'll get much traction on the second point until I take care of the first.

In the bigger picture, this will be covered by the plan to make all SVG parsing in HTML case-insensitive.  However, the exact details for implementing that are still being debated.

I'll follow-up when this is actionable.
looks like SVG 2 will drop allowReorder
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

3 years ago
Thanks for following up, Robert.

Normative text isn't in the spec yet, but the SVG working group issue is here: https://github.com/w3c/svgwg/issues/136

As Robert notes in Bug 1279690, the resolution is to always have the allowReorder behavior and therefore not need the attribute and special HTML parser rules for it.
Flags: needinfo?(amelia.bellamy.royds)
You need to log in before you can comment on or make changes to this bug.