Last Comment Bug 116762 - vertical-align: set on anchor crops an image within it
: vertical-align: set on anchor crops an image within it
Status: RESOLVED DUPLICATE of bug 118501
[DUPEME][CSS1-5.4.4]
: css1, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 All
: P3 normal with 1 vote (vote)
: Future
Assigned To: layout.tables
: Madhur Bhatia
:
Mentors:
http://anchor.net.au/broken.html
: 87767 163844 269953 (view as bug list)
Depends on: 118501
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-24 05:19 PST by mozilla
Modified: 2010-07-29 10:57 PDT (History)
6 users (show)
bernd_mozilla: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (339 bytes, text/html)
2001-12-30 17:37 PST, Mats Palmgren (:mats)
no flags Details
testcase without table and anchor (571 bytes, text/html)
2007-11-28 16:08 PST, Jonathan Haas
no flags Details
bug116762-reftests (1.72 KB, application/octet-stream)
2009-05-19 10:46 PDT, Aaron Train [:aaronmt]
no flags Details
bug116762-reftests (1.72 KB, patch)
2009-05-19 10:47 PDT, Aaron Train [:aaronmt]
dbaron: review-
Details | Diff | Splinter Review

Description mozilla 2001-12-24 05:19:01 PST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

The image is not displayed properly. Only a small part is displayed
and that part also shown outside the table. Depends on vertical-align
being set on <A> tag.

Image displays improperly tested on Linux (0.96 & 0.97) and on Windows
(0.96).

Image displays correctly on Netscape 4.7x, Konqueror 2.1.1, and IE 5.1.

Reproducible: Always
Steps to Reproduce:
1.View page given with Mozilla


Actual Results:  Image not displayed properly/fully.

Expected Results:  Image should have been displayed.

See URL given above and corresponding style sheet.
All pages above pass http://validator.w3.org
Comment 1 Mats Palmgren (:mats) 2001-12-30 17:37:29 PST
Created attachment 63097 [details]
Testcase
Comment 2 Mats Palmgren (:mats) 2001-12-30 17:40:38 PST
Confirming and reasssigning to HTMLTables.
Comment 3 karnaze (gone) 2002-01-07 09:38:12 PST
Temporarily moving to future until a milestone can be assigned. 
Comment 4 anthonyd 2002-01-30 16:13:47 PST
this can be re-worked around by attaching the align to the image instead of the 
anchor.  this is a dupe of another bug which i cannot seem to find yet right 
now.
Comment 5 Mats Palmgren (:mats) 2002-08-23 10:53:09 PDT
*** Bug 163844 has been marked as a duplicate of this bug. ***
Comment 6 karnaze (gone) 2003-03-31 10:53:07 PST
mass reassign to default owner
Comment 7 HARUNAGA Hirotoshi 2004-05-26 07:37:47 PDT
*** Bug 87767 has been marked as a duplicate of this bug. ***
Comment 8 Bernd 2004-08-22 11:36:04 PDT
wfm winxp 2004080708

Mats is that really wfm or do I overlook something?
Comment 9 Mats Palmgren (:mats) 2004-08-22 17:12:32 PDT
I think that the top of "XXX" should be aligned with the top of the image,
both aligned at the top of the cell which is high enough to fit its contents.
I think there is a Block/Inline bug somewhere on the align issue (bug 118501?)
Comment 10 Mats Palmgren (:mats) 2004-08-22 18:38:51 PDT
Well, after reading the spec, I now think that "XXX" should stay on the baseline.
http://www.w3.org/TR/CSS21/visudet.html#propdef-vertical-align

That is, the testcase should render exactly as if the 'vertical-align' had not
been specified...
Comment 11 Erik Fabert 2004-11-15 09:58:21 PST
*** Bug 269953 has been marked as a duplicate of this bug. ***
Comment 12 Jonathan Haas 2007-11-28 16:08:13 PST
Created attachment 290614 [details]
testcase without table and anchor

this happens also with generic div and span elements.
Comment 13 Bernd 2009-04-20 11:19:22 PDT
this did not work before 1.9 but does now.
Comment 14 David Baron :dbaron: ⌚️UTC-10 2009-04-20 11:38:43 PDT

*** This bug has been marked as a duplicate of bug 118501 ***
Comment 15 Ryan VanderMeulen [:RyanVM] 2009-04-20 11:44:58 PDT
Bernd, is testcase 2 correct in saying that the image should be inside the box in both cases? If that's true, then it still isn't passing for me on 3.0.9. The image bleeds through the top box. On the other hand, given the bug title, I would be inclined to at least say that it's a different bug if it is indeed one.
Comment 16 David Baron :dbaron: ⌚️UTC-10 2009-04-20 11:50:53 PDT
bug 118509 was fixed in 3.1a1, i.e., after 3.0.*.
Comment 17 Aaron Train [:aaronmt] 2009-05-19 10:46:37 PDT
Created attachment 378382 [details]
bug116762-reftests
Comment 18 Aaron Train [:aaronmt] 2009-05-19 10:47:31 PDT
Created attachment 378383 [details] [diff] [review]
bug116762-reftests
Comment 19 David Baron :dbaron: ⌚️UTC-10 2009-05-19 13:35:34 PDT
Did you test that your test fails before the bug was fixed?  Did you check that it passes in the reftest harness?
Comment 20 David Baron :dbaron: ⌚️UTC-10 2009-07-08 14:48:44 PDT
Comment on attachment 378383 [details] [diff] [review]
bug116762-reftests

Marking as review-denied to prompt a response to the question in the previous comment.  When you answer, please re-request review (set the flag back to "?" and fill in my email in the box).

Note You need to log in before you can comment on or make changes to this bug.